Closed Bug 1388266 Opened 2 years ago Closed 2 years ago

Console error when no _locales dir in unpacked extension

Categories

(WebExtensions :: General, defect, P3)

56 Branch
defect

Tracking

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: dietrich, Assigned: robwu)

References

Details

(Keywords: regression)

Attachments

(2 files)

Screenshot attached
Summary: error when no local dir → error when no locale dir
I got this too. Things still seemed to work though.
Priority: -- → P3
Duplicate of this bug: 1392354
Summary: error when no locale dir → Console error when no _locales dir in unpacked extension
This is a regression in 56, caused by bug 1364768.

Patch is simple. Is logspam a good reason to request a merge to beta?
Assignee: nobody → rob
Keywords: regression
See Also: → 1364768
Version: unspecified → 56 Branch
Comment on attachment 8905566 [details]
Bug 1388266 - Ignore error about non-existing _locale and localization directory

https://reviewboard.mozilla.org/r/177368/#review182442

::: toolkit/components/extensions/Extension.jsm:397
(Diff revision 1)
>            results.push(entry);
>          });
>        } catch (e) {
>          // Always return a list, even if the directory does not exist (or is
>          // not a directory) for symmetry with the ZipReader behavior.
> +        if (!(e instanceof OS.File.Error && e.becauseNoSuchFile)) {

No need for the instanceof check. Just `!e.becauseNoSuchFile`
Attachment #8905566 - Flags: review?(kmaglione+bmo) → review+
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/81a4056d2031
Ignore error about non-existing _locale and localization directory r=kmag
https://hg.mozilla.org/mozilla-central/rev/81a4056d2031
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Please request Beta approval on this when you get a chance.
Flags: needinfo?(rob)
Comment on attachment 8905566 [details]
Bug 1388266 - Ignore error about non-existing _locale and localization directory

Approval Request Comment
[Feature/Bug causing the regression]: bug 1364768
[User impact if declined]: An error message appears in the console when the user loads a temporary add-on at about:debugging.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Yes, load a temporary add-on at about:debugging and look at the console - the reported error message does not show up any more.
[Needs manual test from QE? If yes, steps to reproduce]: Not needed.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is a small patch that suppresses one error message without other functional or logical changes.
[String changes made/needed]: N/A
Flags: needinfo?(rob)
Attachment #8905566 - Flags: approval-mozilla-beta?
Comment on attachment 8905566 [details]
Bug 1388266 - Ignore error about non-existing _locale and localization directory

Fix an error related to extension. Beta56+.
Attachment #8905566 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Rob Wu [:robwu] from comment #10)
> [Needs manual test from QE? If yes, steps to reproduce]: Not needed.
Setting qe-verify flag to -, per Rob's assessment on manual testing needs.
Flags: qe-verify-
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.