stylo: Crash in mozilla::DeclarationBlock::AsGecko

RESOLVED WORKSFORME

Status

()

P2
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: marcia, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression})

Trunk
Unspecified
Windows 10
crash, regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 verified, firefox57 verified)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-15705731-6122-4c02-ac77-fa7250170808.
=============================================================

Seen while looking at nightly crash stats - these crashes go back to when 56 was in nightly and started in 20170720030203: http://bit.ly/2vi6xLz

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1b065ffd8a535a0ad4c39a912af18e948e6a42c1&tochange=0985725c848ec0cfc6f2f3c3a5aa3d71321e7620
Hiro-san, could it be a stylo regression from bug 1381431?
Flags: needinfo?(hikezoe)
Priority: -- → P2
I don't think bug 1381431 caused the crashes.  I guess this crash was caused by fusing style context (bug 1367904).
Also it seems to me that this crash has been fixed in 20170808 nightly.  I think Manish already fixed the crash.
Keep ni to me, I will revisit the crash report after this weekend.
There are no more crash reports after build id 20170808114032. This crash is probably fixed, as Hiro noted.

https://crash-stats.mozilla.com/signature/?product=Firefox&signature=mozilla%3A%3ADeclarationBlock%3A%3AAsGecko#reports
Blocks: 1388178
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
Summary: Crash in mozilla::DeclarationBlock::AsGecko → stylo: Crash in mozilla::DeclarationBlock::AsGecko
Yeah.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hikezoe)
Resolution: --- → WORKSFORME
status-firefox56: affected → verified
status-firefox57: affected → verified
You need to log in before you can comment on or make changes to this bug.