[10.13] Online videos do not work if video quality is under 360p

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
P2
normal
RESOLVED WORKSFORME
4 months ago
2 months ago

People

(Reporter: asimonca, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox55 wontfix, firefox56+ wontfix, firefox57+ wontfix)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Created attachment 8894863 [details]
macos bug.png

[Note]:
- This bug is macOS High Sierra 10.13 specific

[Affected versions]:
- ESR 52.3.9, RC 55.0, Beta 56.0b1, Nightly 57.0a1

[Affected platforms]:
- macOS High Sierra 10.13

[Steps to reproduce]:
1. Open Firefox.
2. Go to www.youtube.com or other video site that supports selecting video quality under 360p (e.g. www.dailymotion.com)
3. Open a video and select 240p or 144p.

[Expected result]:
- The video is loaded with the selected video resolution.

[Actual result]:
- The video does not work and the player displays an error message.

[Regression range]:
- This is not a regression since it only affects macOS 10.13 Beta 

[Additional notes]:
- Please see the attachments for the youtube error code.
Hello Alexandru - which seed are you testing on? A new seed was just released today.
(Reporter)

Comment 2

4 months ago
Hello Marcia,
I've tested it on the Beta 4 (17A315i) seed. I used Public Beta 4 for this testing and the one that was released today is the Developer Beta 5. I'll get that one tomorrow and test this again.

Updated

4 months ago
Priority: -- → P2
Whiteboard: tpi:+
(Reporter)

Comment 3

4 months ago
Still happens in yesterday's seed: 17A330h

Comment 4

4 months ago
I can confirm Build 17A330h 10.13, and Firefox 55 and Firefox 56 Dev edition cannot play videos from youtube and vimeo
Marcia, would you mind filing a bug with apple?
Flags: needinfo?(mozillamarcia.knous)
status-firefox55: affected → wontfix
tracking-firefox56: --- → +
tracking-firefox57: --- → +
In the latest seed,17A352a using the latest nightly I cannot reproduce this issue - I played several youtube videos and was able to play them at both 144 and 240.
Flags: needinfo?(mozillamarcia.knous)

Comment 7

3 months ago
Hi Alexandru,
Can you help check if this issue is still reproducible with Beta56 on build 17A352a?
status-firefox56: affected → wontfix
Flags: needinfo?(alexandru.simonca)

Updated

3 months ago
status-firefox56: wontfix → affected
(Reporter)

Comment 8

3 months ago
Just tested again on build 17A360a with Beta 56b12 and the issue is no longer reproducible.
Flags: needinfo?(alexandru.simonca)
Fixed on Apple's side, resolving this one as WFM to get it off the radar.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
Per comment #9, mark 56/57 won't fix.
status-firefox56: affected → wontfix
status-firefox57: affected → wontfix
status-firefox-esr52: affected → wontfix
You need to log in before you can comment on or make changes to this bug.