Preferences panel text is huge

RESOLVED DUPLICATE of bug 1392532

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1392532
9 months ago
8 months ago

People

(Reporter: gcp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 months ago
Since ~2 days, the text in the preferences panel is so large it no longer fits on the screen and I get dual scrollbars.

The text size doesn't correspond to any setting on my desktop and is far larger than any other text in Firefox.

I'll try to bisect this, as it happens on a clean profile.
(Reporter)

Comment 1

9 months ago
The first bad revision is:
changeset:   419703:c3910ce15bbb
parent:      419663:347ea0d06092
user:        Evan Tseng <evan@tseng.io>
date:        Mon Jul 24 16:49:16 2017 +0800
summary:     Bug 1377167 - Update font size, font color, and background color to match the Photon preferences visual refresh spec. r=mconley
Blocks: 1377167

Updated

9 months ago
Whiteboard: [photon-preference][triage]
(Reporter)

Comment 2

9 months ago
Created attachment 8895334 [details]
Screenshot of mismatch of font sizes

Here's a screenshot of how my desktop ends up looking. The font size of Firefox's preferences is completely out of whack.

Comment 3

8 months ago
Hi Gian-Carlo,

I think the RWD patch (Bug 1386514) could fix this.

And could you tell me what is you window size in the screenshot[1]?

Thank you.

[1]: https://bug1388414.bmoattachments.org/attachment.cgi?id=8895334
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1386514

Comment 4

8 months ago
The patch in bug 1386514 does not change the text size. It's still oversized even if bug 1386514 may solve the scrolling issue.
Status: RESOLVED → REOPENED
Depends on: 1386514
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

8 months ago
(In reply to Evan Tseng [:evanxd] from comment #3)
> And could you tell me what is you window size in the screenshot[1]?
>

The screen is a 1920x1200 (forced to 96x96 dpi), so about 1000x1100 or thereabouts.

Comment 6

8 months ago
Hi Gian-Carlo,

Thank you for the info.

Let's check the issue again after Bug 1386514 and Bug 1377174 are landed since they will change some container's size (or margin size).
Depends on: 1377174

Updated

8 months ago
Depends on: 1388348

Updated

8 months ago
Depends on: 1392532
No longer depends on: 1388348

Updated

8 months ago
No longer depends on: 1392532
See Also: → bug 1392532

Comment 7

8 months ago
Created attachment 8899759 [details]
linux-width-1000px.png

Please check the screenshot (attachment) of Preferences page after Bug 1377174 and Bug 1386514 are landed, there is no horizontal scroller anymore when window width is about 1000px.

Updated

8 months ago
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1386514

Comment 9

8 months ago
(In reply to Evan Tseng [:evanxd] from comment #7)
> Created attachment 8899759 [details]
> linux-width-1000px.png
> 
> Please check the screenshot (attachment) of Preferences page after Bug
> 1377174 and Bug 1386514 are landed, there is no horizontal scroller anymore
> when window width is about 1000px.

Good to see that the scrolling issue is resolved, but as noted earlier, the text is still unusually and unnecessarily big. What's up with that?
Status: RESOLVED → REOPENED
Flags: needinfo?(evan)
Resolution: DUPLICATE → ---
Summary: Preferences panel text is huge, scrolls of screen → Preferences panel text is huge

Comment 10

8 months ago
Hi Dão,

We will fix the huge font size issue on Bug 1392532.

Thank you for mentioning it.
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago8 months ago
Flags: needinfo?(evan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1392532

Comment 11

8 months ago
remove whiteboard tag due to its DUPLICATE
Whiteboard: [photon-preference][triage]
You need to log in before you can comment on or make changes to this bug.