Build with rust in parallel?

RESOLVED DUPLICATE of bug 1353472

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1353472
4 months ago
4 months ago

People

(Reporter: mayhemer, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
Win64, m-c, optimized build.  

I can see:

 6:35.17 jsapi-tests.exe
 7:14.77    Compiling geckoservo v0.0.1 (file:///C:/Mozilla/src/mozilla-central2/servo/ports/geckolib)
 8:36.50 note: link against the following native artifacts when linking against this static library
 8:36.50
 8:36.50 note: the order and any duplication can be significant on some platforms, and so may need to be preserved
 8:36.50
 8:36.50 note: library: advapi32
 8:36.50
 8:36.50 note: library: kernel32
 8:36.50
 8:36.50 note: library: advapi32
 8:36.50
 8:36.50 note: library: ws2_32
 8:36.50
 8:36.51 note: library: userenv
 8:36.51
 8:36.51 note: library: shell32
 8:36.51
 8:36.51 note: library: msvcrt
 8:36.51
 8:37.25    Compiling gkrust-shared v0.1.0 (file:///C:/Mozilla/src/mozilla-central2/toolkit/library/rust/shared)
 8:38.25    Compiling gkrust v0.1.0 (file:///C:/Mozilla/src/mozilla-central2/toolkit/library/rust)
12:01.47 note: link against the following native artifacts when linking against this static library
12:01.47
12:01.47 note: the order and any duplication can be significant on some platforms, and so may need to be preserved
12:01.47
12:01.47 note: library: advapi32
12:01.47
12:01.47 note: library: gdi32
12:01.47
12:01.47 note: library: kernel32
12:01.47
12:01.47 note: library: advapi32
12:01.47
12:01.47 note: library: ws2_32
12:01.47
12:01.47 note: library: userenv
12:01.47
12:01.47 note: library: shell32
12:01.47
12:01.47 note: library: msvcrt
12:01.47
12:01.54     Finished release [optimized] target(s) in 674.34 secs
12:01.61 xul_s.lib.desc
12:01.61 xul.dll


while there is always only one rustc process running at the time.  could this be parallelized?

Comment 1

4 months ago
Possibly a dupe of bug 1353472?

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353472
You need to log in before you can comment on or make changes to this bug.