Closed Bug 1388734 Opened 5 years ago Closed 5 years ago

CustomTab: download is not working

Categories

(Firefox for Android Graveyard :: General, defect)

57 Branch
ARM
Android
defect
Not set
normal

Tracking

(fennec+, firefox57 affected)

RESOLVED DUPLICATE of bug 1393128
Tracking Status
fennec + ---
firefox57 --- affected

People

(Reporter: sflorean, Unassigned)

References

Details

Environment: 
Device: HTC 10 (Android 7.0);
Build: Nightly 57.0a1 (2017-08-09);
Prerequisites: enable Custom tabs in settings.

Steps to reproduce:
1. Launch Custom tab activity;
2. Download a pdf file or video, images.

Expected result:
The files are downloaded with no issues and each file has the correct icon in Downloads folder in Fennec.
Pause/resume/cancel options from notification area works as expected.

Actual result:
Nothing happens.

Notes:
Long tap on images/videos don't bring context menu.
For pdf files (with direct link) nothing happens.
Yeah, this is unfortunate, but I don't think it's going to be ship blocker for the first custom tabs release.
tracking-fennec: ? → +
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1393128
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.