Intermittent testNewTab | application crashed [@ MessageLoop::PostTask_Helper]

RESOLVED DUPLICATE of bug 1392705

Status

()

Firefox for Android
Testing
P5
critical
RESOLVED DUPLICATE of bug 1392705
4 months ago
3 months ago

People

(Reporter: Treeherder Bug Filer, Assigned: gbrown)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell fixed:product], crash signature)

(Reporter)

Description

4 months ago
treeherder
Filed by: philringnalda [at] gmail.com

https://treeherder.mozilla.org/logviewer.html#?job_id=122062754&repo=autoland

https://queue.taskcluster.net/v1/task/XH53FGAOQAOqwTx-wrqt7g/runs/0/artifacts/public/logs/live_backing.log

Comment 1

4 months ago
9 failures in 901 pushes (0.01 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 7
* mozilla-inbound: 2

Platform breakdown:
* android-4-3-armv7-api15: 6
* android-api-15-gradle: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-08-07&endday=2017-08-13&tree=all

Comment 2

4 months ago
15 failures in 949 pushes (0.016 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 9
* mozilla-inbound: 3
* mozilla-central: 2
* try: 1

Platform breakdown:
* android-4-3-armv7-api15: 8
* android-api-15-gradle: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-08-14&endday=2017-08-20&tree=all
I have seen quite a few robocop specific tests failing in the last few weeks- while this failure isn't high frequency to be stockwell, it is trending at the ~20/week line, so frequent enough.  Appears to be on opt specifically.

:snorp, do you have any thoughts on why we have this failure and similarly the uptick in robocop failures?
Flags: needinfo?(snorp)
Not aware of any changes that would've caused this, but things like this are starting to pile up. We're going to try to find some time to stabilize the tests soon.
Flags: needinfo?(snorp)

Comment 5

4 months ago
33 failures in 908 pushes (0.036 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-inbound: 14
* autoland: 13
* mozilla-central: 4
* try: 2

Platform breakdown:
* android-api-15-gradle: 19
* android-4-3-armv7-api15: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-08-21&endday=2017-08-27&tree=all
:snorp- is this something in progress?  I see 47 failures in the last 7 days:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970

the rate of failure seems to be increasing.
Flags: needinfo?(snorp)
Whiteboard: [stockwell needswork]
Randall this is another shutdown crash. Does this look similar to anything else you've been working on?
Flags: needinfo?(snorp) → needinfo?(rbarker)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #7)
> Randall this is another shutdown crash. Does this look similar to anything
> else you've been working on?

Looks like we are trying to post a message to the UI thread message_loop after it has been deleted. May be able to catch it in mozilla::RunAndroidUiTasks? I can take a look.
Flags: needinfo?(rbarker)
Actually, I may have that backwards. Looks like we are trying to post a Runnable to the main thread from the UI thread when the main thread has already shutdown. I'm not sure how to handle that case. I would guess UiCompositorControllerChild::Destroy needs to detect if the main thread is still alive before calling PUiCompositorControllerChild::Close() but I'm not sure how to do that.

Comment 10

4 months ago
15 failures in 233 pushes (0.064 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 9
* mozilla-inbound: 4
* try: 1
* mozilla-central: 1

Platform breakdown:
* android-api-16-gradle: 12
* android-4-3-armv7-api-16: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-08-31&endday=2017-08-31&tree=all

Comment 11

3 months ago
23 failures in 180 pushes (0.128 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 19
* try: 3
* mozilla-central: 1

Platform breakdown:
* android-api-16-gradle: 14
* android-4-3-armv7-api16: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-01&endday=2017-09-01&tree=all

Comment 12

3 months ago
72 failures in 939 pushes (0.077 failures/push) were associated with this bug in the last 7 days. 

This is the #32 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-inbound: 29
* autoland: 24
* mozilla-central: 11
* try: 8

Platform breakdown:
* android-api-16-gradle: 34
* android-4-3-armv7-api-16: 18
* android-4-3-armv7-api16: 16
* android-api-15-gradle: 2
* android-4-3-armv7-api15: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-08-28&endday=2017-09-03&tree=all

Comment 13

3 months ago
18 failures in 205 pushes (0.088 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 8
* autoland: 7
* try: 2
* mozilla-central: 1

Platform breakdown:
* android-api-16-gradle: 10
* android-4-3-armv7-api16: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-06&endday=2017-09-06&tree=all

Comment 14

3 months ago
15 failures in 173 pushes (0.087 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 6
* mozilla-inbound: 5
* try: 4

Platform breakdown:
* android-api-16-gradle: 8
* android-4-3-armv7-api16: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-07&endday=2017-09-07&tree=all

Comment 15

3 months ago
73 failures in 924 pushes (0.079 failures/push) were associated with this bug in the last 7 days. 

This is the #31 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-inbound: 26
* autoland: 24
* try: 17
* mozilla-central: 6

Platform breakdown:
* android-api-16-gradle: 39
* android-4-3-armv7-api16: 34

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-04&endday=2017-09-10&tree=all
(Assignee)

Comment 16

3 months ago
Waiting on bug 1394428 / bug 1392705.
(Assignee)

Updated

3 months ago
Depends on: 1394428

Comment 17

3 months ago
9 failures in 191 pushes (0.047 failures/push) were associated with this bug yesterday.    

** This test has failed more than 200 times in the last 30 days. It should be disabled until it can be fixed. ** 

Repository breakdown:
* mozilla-central: 5
* autoland: 2
* try: 1
* mozilla-inbound: 1

Platform breakdown:
* android-api-16-gradle: 7
* android-4-3-armv7-api16: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-14&endday=2017-09-14&tree=all
Whiteboard: [stockwell needswork] → [stockwell disable-recommended]

Comment 18

3 months ago
62 failures in 1032 pushes (0.06 failures/push) were associated with this bug in the last 7 days. 

This is the #44 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* mozilla-central: 18
* mozilla-inbound: 15
* autoland: 15
* try: 14

Platform breakdown:
* android-api-16-gradle: 32
* android-4-3-armv7-api16: 30

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-11&endday=2017-09-17&tree=all
(Assignee)

Updated

3 months ago
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1392705
(Assignee)

Updated

3 months ago
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:product]

Comment 20

3 months ago
3 failures in 943 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* try: 1
* mozilla-inbound: 1
* mozilla-central: 1

Platform breakdown:
* android-api-16-gradle: 2
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1388970&startday=2017-09-18&endday=2017-09-24&tree=all
You need to log in before you can comment on or make changes to this bug.