Closed Bug 1389024 Opened 7 years ago Closed 7 years ago

2.07 - 3.23% Heap Unclassified (macosx64-stylo, windows10-64-stylo, windows7-32-stylo) regression on push 8e991e3b80f610f1495bc562732a14b374a91a40 (Wed Aug 9 2017)

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: perf, regression)

We have detected an awsy regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=8e991e3b80f610f1495bc562732a14b374a91a40

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  Heap Unclassified summary windows10-64-stylo opt stylo     70,009,897.37 -> 72,268,474.51
  2%  Heap Unclassified summary windows7-32-stylo opt stylo      55,447,308.74 -> 56,630,916.26
  2%  Heap Unclassified summary macosx64-stylo opt stylo         97,594,090.30 -> 99,612,638.33


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8673

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/AWSY
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Tommy, this seems to have landed some memory regressions on multiple platforms. Can we improve these or should we just accept?
Flags: needinfo?(kuoe0)
Bug 1377158 just adds the area where we use stylo, and stylo currently doesn't behave good in terms of memory usage, which is a known issue. I would expect some of the work in bug 1367854 would help mitigate this.
Depends on: 1367854
Flags: needinfo?(kuoe0)
If we plan to fix Stylo memory usage in bug 1367854 and not back out the cause of this particular regression (Stylo SVG-as-an-image bug 1377158), I will just resolve this bug as WONTFIX.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.