Closed Bug 1389063 Opened 6 years ago Closed 6 years ago

Intermittent browser_permmgr_sync.js,browser_privatebrowsing_about.js | A promise chain failed to handle a rejection: Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.initSpecialConnection]

Categories

(Testing :: General, defect, P5)

defect

Tracking

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure)

These started on Beta after uplifting the various throttling patches yesterday. Can you please take a look, Honza?
Flags: needinfo?(honzab.moz)
Summary: Intermittent browser_privatebrowsing_about.js | A promise chain failed to handle a rejection: Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.initSpecialConnection] → Intermittent browser_permmgr_sync.js,browser_privatebrowsing_about.js | A promise chain failed to handle a rejection: Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.initSpecialConnection]
This is very likely *unrelated* to the throttling patches.  Comapred to m-c where there is no such issue, the http sub-module code is nearly identical, the files containing the throttling feature and these changes are identical byte-by-byte.
Flags: needinfo?(honzab.moz)
Running various backouts through Try is pointing to bug 1386533 as the culprit. Sorry for the false alarm. Will be backing that out shortly.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
And now I can reproduce these failures going back 2 days. I'm beginning to wonder if something changed in our test environment...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Something likely changed in the test environment here - addr in use is what'll happen if 2 processes try to open a socket on the same port. Maybe some chunking of tests changed? Or perhaps something getting stuck in the environment? Not sure, but this really doesn't look like a necko issue. Putting in testing for now, so someone there can take a look.
Component: Networking → General
Product: Core → Testing
FWIW, these failures only appear on Beta, which makes me doubt the theory about it being infra-related. I've also seen them on some recent Trunk-as-Beta Try simulations.
Maybe my patch on bug 1254136 fixed that. Ryan uplifted it on Friday last week. Maybe we should wait some days and then check again.
Looks like it did!
Assignee: nobody → hskupin
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Depends on: 1254136
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.