Closed Bug 1389342 Opened 4 years ago Closed 4 years ago

Weird alignment of device icons in Synced History

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

defect
Not set
normal

Tracking

(fennec+, firefox57 verified)

VERIFIED FIXED
Firefox 57
Tracking Status
fennec + ---
firefox57 --- verified

People

(Reporter: Grisha, Assigned: jwu)

References

Details

(Whiteboard: [FNC][SPT57.2][INT])

Attachments

(2 files)

Attached image history-sync.png
See screenshot. Seems like row elements are evenly spaced out.
Component: General → Awesomescreen
tracking-fennec: --- → ?
Looks like this issue is caused by Photon with new icons.
Assignee: nobody → topwu.tw
This regression is caused by bug 1383736 that the value of 'favicon_bg' in dimens.xml is changed from '32dp' to '112dp'. 

But since the size of favicon in TwoLinePageRow has been changed to refer 'favicon_small_size', device icons in history page should use its value as width and height to keep all icons have identical size in history page.
[Triage@0816] Max, would you help set it tracking-fennec:+ with P1 as Jingwei is on it already? Thanks.
Flags: needinfo?(max)
Comment on attachment 8897741 [details]
Bug 1389342 - Use value of 'favicon_small_size' as width/height for device icon in history page.

https://reviewboard.mozilla.org/r/169042/#review174536
Attachment #8897741 - Flags: review?(cnevinchen) → review+
Duplicate of this bug: 1391377
Comment on attachment 8897741 [details]
Bug 1389342 - Use value of 'favicon_small_size' as width/height for device icon in history page.

https://reviewboard.mozilla.org/r/169042/#review175176
Attachment #8897741 - Flags: review?(walkingice0204) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c289e7c3995d
Use value of 'favicon_small_size' as width/height for device icon in history page. r=nechen,walkingice
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c289e7c3995d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
tracking-fennec: ? → +
Flags: needinfo?(max)
Verified as fixed on Nightly 57 (2017-08-24).
Devices:
Xiaomi Mi Pad 2 (Android 5.1)
Oneplus Two (Android 6.0.1)
Prestigio Grace X5 (Android 4.4.2)
Status: RESOLVED → VERIFIED
Whiteboard: [FNC][SPT57.2][INT]
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.