Closed Bug 1389519 Opened 2 years ago Closed 2 years ago

paymentUIService.js is visible in startup profiles

Categories

(Firefox :: WebPayments UI, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1382388

People

(Reporter: florian, Unassigned)

References

(Blocks 1 open bug)

Details

Here is a warm startup profile on a slow machine: https://perfht.ml/2uNgWx2

1. Does this file really need to be loaded before first paint? It's currently loaded by http://searchfox.org/mozilla-central/rev/4b79f3b23aebb4080ea85e94351fd4046116a957/toolkit/components/payments/payments.manifest#3

2. The 2 lazy getters defined at http://searchfox.org/mozilla-central/rev/4b79f3b23aebb4080ea85e94351fd4046116a957/toolkit/components/payments/paymentUIService.js#14 are triggered immediately by the PaymentUIService constructor. So either they shouldn't be lazy getters, or the constructor code needs fixing.
paymentSrv.setTestingUIService(this); was a temporary approach until the DOM code did the right thing. This will all go away now that bug 1382092 is fixed.

Note that this code is Nightly-only and not riding the trains for now.
Depends on: 1382092
This is being fixed by bug 1382388.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382388
Product: Toolkit → Firefox
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.