Reload/stop button's animation seems to stop after entering/exiting Customize mode.

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: KWierso, Assigned: jaws)

Tracking

({regression})

unspecified
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [reserve-photon-animation])

Attachments

(1 attachment)

Reporter

Description

2 years ago
I'm on today's Win64 Nightly build (I think the first one where the flexible spaces were added around the location bar?), and noticed that the stop/reload button's animation stopped working. Only noticed it after I went into Customize mode and removed the flexible spaces. 

The animations returned when I restarted my browser session, but go away the moment I go into and then leave customize mode. I don't have to make any actual customization changes, just enter/leave customize mode.

:Bkelly is seeing the same thing, but jaws doesn't.
This is broken because http://searchfox.org/mozilla-central/rev/33295c6f4d57d16fe76476ac131cadd4cd3d05ad/browser/base/content/browser-customization.js#41 calls CombinedStopReload.uninit() on entering customize mode (not a problem so far), and then http://searchfox.org/mozilla-central/rev/33295c6f4d57d16fe76476ac131cadd4cd3d05ad/browser/base/content/browser-customization.js#71 calls CombinedStopReload.init() when exiting customize mode (here's the problem).

CombinedStopReload.init() sets this.animate=false and since the pref doesn't change, startAnimationPrefMonitoring() isn't going to set it back to true.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(felipc)
Iteration: --- → 57.1 - Aug 15
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [reserve-photon-animation]

Comment 4

2 years ago
mozreview-review
Comment on attachment 8896496 [details]
Bug 1389621 - Don't set this.animate=false during CombinedStopReload.init since pref monitoring is not guaranteed to run after init(), such is the case when exiting customize mode.

https://reviewboard.mozilla.org/r/167750/#review173646
Attachment #8896496 - Flags: review?(felipc) → review+

Comment 5

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/180faf6c0402
Don't set this.animate=false during CombinedStopReload.init since pref monitoring is not guaranteed to run after init(), such is the case when exiting customize mode. r=Felipe
Iteration: 57.1 - Aug 15 → 57.2 - Aug 29

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/180faf6c0402
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Updated

2 years ago
Depends on: 1391146
Flags: qe-verify? → qe-verify+
QA Contact: stefan.georgiev
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build   ID    20170905100117

This bug fix is Verified with latest Nightly 57.0a1.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.