Incorrect checksum on ftp.mozilla.org for nightly

RESOLVED DUPLICATE of bug 1389361

Status

Release Engineering
General
--
major
RESOLVED DUPLICATE of bug 1389361
6 days ago
6 days ago

People

(Reporter: sylvestre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 days ago
$ curl -O https://ftp.mozilla.org/pub/firefox/nightly/latest-date/firefox-57.0a1.en-US.linux-x86_64.tar.bz2
$ curl -O https://ftp.mozilla.org/pub/firefox/nightly/latest-date/firefox-57.0a1.en-US.linux-x86_64.checksums

$ grep $(sha256sum firefox-57.0a1.en-US.linux-x86_64.tar.bz2|cut -d" " -f1) firefox-57.0a1.en-US.linux-x86_64.checksums|wc -l
0
$ grep $(sha512sum firefox-57.0a1.en-US.linux-x86_64.tar.bz2|cut -d" " -f1) firefox-57.0a1.en-US.linux-x86_64.checksums|wc -l
0

Obviously, we should get 1
(Reporter)

Comment 1

6 days ago
Reported here:
I suspect it's merely a time between upload and checksum upload that this user got caught in, however there have been changes related to signing linux done on date in support of another endeavor .

Due to me not being at a keyboard I'm just going to ni to Aki about it.
Flags: needinfo?(aki)

Comment 3

6 days ago
a) Why are people looking at date? It's a project branch. Right now we're testing bug 1389361 on it, but it's never intended for general audiences.
b) bug 1389361 helps me test the new signing logic, but breaks beetmover, so we don't get checksums uploaded.
Status: NEW → RESOLVED
Last Resolved: 6 days ago
Flags: needinfo?(aki)
Resolution: --- → DUPLICATE
Duplicate of bug: 1389361

Comment 4

6 days ago
We should probably point them at https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/ or https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n/
You need to log in before you can comment on or make changes to this bug.