Mail won't load if I've started and closed navigator using quicklaunch at this time, not sure if it matters.

VERIFIED DUPLICATE of bug 144027

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED DUPLICATE of bug 144027
16 years ago
14 years ago

People

(Reporter: Zach Lorden, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

I use quicklaunch with Navigator and Mail, but if I'm browsing using Navigator,
and close it, Mail won't load anymore.  The "Exit Mozilla" option is also greyed
out on the quicklaunch icon.

Reproducible: Always
Steps to Reproduce:
1.  With Quicklaunch enabled, start Navigator
2.  Close Navigator
3.  Attempt to load Mail

Actual Results:  Mail did not load, and the "Exit Mozilla" option is greyed out.

Expected Results:  Loaded mail.

Sorry if I didn't catergorize it correctly...I wasn't sure what to use
(Reporter)

Comment 1

16 years ago
Correction: I have to restart Navigator in order for the bug to take place.  So
to reproduce:

1.  With Quicklaunch enabled, start Navigator
2.  Close Navigator
3.  Load Navigator
4.  Attempt to load Mail

Comment 2

16 years ago
WFM
I have
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
Tested about 10 times but I can't reproduce.

Comment 3

16 years ago
Build ID: 2002041711
Platform: Win98

Opening and closing mail also seems to cause this for me.  To reproduce:
1. Quick Launch is enabled
2. Open browser and mail
3. Close mail
4. Attempt to reopen mail using any method (i.e., quicklaunch, browser menu,
component bar)

Results: mail doesn't open

Comment 4

16 years ago
I still can't reproduce.
Did you both did a clean install of mozilla?

Comment 5

16 years ago
Happens to me too. 
Running "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1) Gecko/20020422"

And I did a clean install and also cleaned up some entries in the prefs.js.

This is a real showstopper... The steps to reproduce are the same already posted
here.

Comment 6

16 years ago
I get the same results as #3 using a Win95 machine.

Additionally: if I use the Quick Launch tray icon to attempt to load MailNews,
the Window menu reflects that I have another window open -- it's labeled 2 (with
1 being my Navigator window) but it has no title and clicking it does nothing
except remove focus from the Navigator window.  Each such Quicklaunch attempt
adds another phantom window to the list (I have 6 currently, but haven't tried
to find an upper limit).

Comment 7

16 years ago
I forgot to mention these quirks reported in #6. They happen here too.

And it seems not to be bound to the QuickLaunch feature: if you open Mail and
News from a Navigator window and then close the M&N window, the module is still
loaded and checks for new e-mail every "x" minutes; then if you double-click the
*extremely ugly* (hint!!) mail icon on systray, it won't open a M&N window, but
rather a "ghost" 2, 3, 4 etc window as reported on #6.

Weird. Still using Build 2002042206.

Comment 8

16 years ago
Win2K sp2, Moz RC1 not clean install, not using quick-launch

Mail won't launch by clicking Mail-icon when I close Moz and relaunch it. On
relaunching browser will not display splash. Need to close it by killing the
process to make it launch w. splash-screen and launch Mail normally.

If I set mail to load by default, browser launches instead in the above
circumstances.

r. vva

Comment 9

16 years ago
P.S. build 2002041711

r. vva

Comment 10

16 years ago
Still happens, but worst this time. Mail and News is simply refusing to run, my
success rate is lower than 1 out of 5 tries. It doesn't matter if I try to start
it directly with quicklaunch disabled, it's just not running.

The Mozilla image is loaded to memory but there's no display, which makes it
necessary to kill the process, else it will lurk there, a perfect invisible zombie.

Heck...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0+) Gecko/20020512

Comment 11

16 years ago
WORKAROUND!!

0) Make *sure* Mozilla is unloaded!!
1) Find the folder where your profiles are stored (e.g., c:\documents and
settings\myname\application data\mozilla)
2) Rename Mozilla's folder to something else. I renamed mine to mozilla0.
3) Start Mozilla. You will notice it's going to recreate the mozilla folder you
just renamed.
4) Tune your preferences, re-add your mail accounts; DON'T DOWNLOAD ANY MAIL.
Cancel the password prompts.
5) Close Mozilla. Make sure it's fully unloaded.
6) Open [snip]\mozilla\Profiles\default\random.slt\ and copy your Mail and
ImapMail folders from the renamed folder (mine was mozilla0, as told before) to
the new location. Replace files as needed. Also copy your bookmark file.
7) Start Mozilla. It should now work properly! If everything is OK, you may
delete the renamed folder.

By doing this you are probably going to lose Personal Security settings and
stuff, so make sure you remember all your passwords =)

I believe this erratic behavior is caused by file corruptions or weird prefs.js
settings. Anyway, things now work 100% OK, if not by a cosmetic bug where if I
double-click that hideous "you got new mail" taskbar icon, the M&N window is
sized as large as your screen resolution is, and can't be resized afterwards
(the "maximize or return to previous size" window button is grayed out). I
believe this bug was already filled.

Comment 12

16 years ago
Please go to Bug 144027 as this is exactly what they reported there, but the
stuff in there is way more detailed.
Reporter: please uninstall all third-aprty Themes, restart and try it again..

Comment 14

16 years ago
Reporter, I'm going to mark this a dup of 144027, comment in the summary that
quick launch may not be the cause and verify it.  If you have tried the request
in comment #13 and still see the problem only when quick launch is on, please
reopen.

*** This bug has been marked as a duplicate of 144027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
QA Contact: olgam → esther
Resolution: --- → DUPLICATE
Summary: Mail won't load if I've started and closed navigator using quicklaunch. → Mail won't load if I've started and closed navigator using quicklaunch at this time, not sure if it matters.

Comment 15

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.