Display more than one line of resources in project info

RESOLVED FIXED

Status

Webtools
Pontoon
P3
normal
RESOLVED FIXED
10 months ago
3 months ago

People

(Reporter: tchevalier, Assigned: mathjazz, Mentored)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Looks like we can’t display more than one line of resources in the project info, would it be possible to allow multiple lines?

I’ve reproduced the issue here https://mozilla-pontoon-staging.herokuapp.com/fr/copyright-campaign/ and worked around it on production.

Note the truncated line "Resources     Development site · Production site · Landing pa…"
(Assignee)

Updated

10 months ago
Priority: -- → P3
(Assignee)

Updated

5 months ago
Mentor: m
Yeah, I just added another resource to the Focus Android project (and notified the dev-l10n mailing list about it) - but now most aren't displayed anymore, so localizers can't choose them (or see they exist) on Pontoon.
Out of 5 Resources available, one can only really see 2 (and the 3rd one is badly truncated): https://pontoon.mozilla.org/projects/focus-for-android/
SOS! :)
(Assignee)

Comment 2

3 months ago
Until this is fixed, I suggest to rename Resources to something shorter, e.g. Schedule, Screenshots, Docs, Dashboard. Those for fit into one line. And Screenshots GitHub is maybe not necessary, because you can guess it from the Screenshots URL?

Comment 3

3 months ago
im wondering if this could be fixed with either a tooltip or a dropdown for the additional resources.

We could use an elipsis (...) or up/down arrow to indicate that there are more resources available
(Assignee)

Comment 4

3 months ago
Created attachment 8958491 [details]
Screen Shot 2018-03-13 at 16.05.17.png

We could also just break into a new line. It's not the prettiest thing, but at least you don't need to click to reveal the rest of the links.

Comment 5

3 months ago
would defo be easier 8)
(Assignee)

Comment 6

3 months ago
Taking because I had to fix it locally to create the screenshot. ;)
Assignee: nobody → m

Comment 8

3 months ago
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/9a51796a9638bbfbdbd5a4dd1d97ca90c20d9734
Fix bug 1389820: Break resources into new lines if needed (#896)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.