Closed Bug 1390022 Opened 2 years ago Closed 2 years ago

Extend the blacklist of disabling adaptive playback feature for Galaxy S4 SPH-L720 model

Categories

(Firefox for Android :: Audio/Video, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox55 --- fixed
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: JamesCheng, Assigned: JamesCheng)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Bug 1360626 comment 39 reported that the S4 L720 (sprints version) also had video corruption issue.

We haven't block this model of S4 device.
Hi kickstand03,

Is it ok for you to provide the log from 'adb logcat'?

I need to ensure whether the model Id is 'SPH-L720' or not.

You can search keyword "The device ModelID is" and paste the full sentence for me.

Thank you.
Flags: needinfo?(kickstand03)
Attachment #8896826 - Flags: review?(jolin)
Comment on attachment 8896826 [details]
Bug 1390022 - Add Galaxy S4 SPH-L720 model into blacklist for disabling adaptive playback feature.

https://reviewboard.mozilla.org/r/168122/#review173290
Attachment #8896826 - Flags: review?(jolin) → review+
(In reply to James Cheng[:JamesCheng] from comment #2)
> Hi kickstand03,
> 
> Is it ok for you to provide the log from 'adb logcat'?
> 
> I need to ensure whether the model Id is 'SPH-L720' or not.
> 
> You can search keyword "The device ModelID is" and paste the full sentence
> for me.
> 
> Thank you.

Hi kickstand03,


If you cannot get the 'adb logcat', please install apk from [1] and play a youtube video.

This apk will show up a notification like [2].

Please screen shot or tell me the string you saw.

Thanks.

[1] https://queue.taskcluster.net/v1/task/RkjSiMRUS5yTCpFiKsMZGw/runs/0/artifacts/public/build/target.apk
 
[2] https://bug1363547.bmoattachments.org/attachment.cgi?id=8870786
Hey this is from my logcat: D/GeckoHardwareCodecCapabilityUtils( 5686): The device ModelID is SPH-L720.
Flags: needinfo?(kickstand03)
Thank you for the feedback.
Pushed by jacheng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6655fafcd81f
Add Galaxy S4 SPH-L720 model into blacklist for disabling adaptive playback feature. r=jolin
You're welcome, and thanks for the help. 
Do I just wait for the next update or does it automatically fix itself? Do I need to do anything else?
Flags: needinfo?(jacheng)
Comment on attachment 8896826 [details]
Bug 1390022 - Add Galaxy S4 SPH-L720 model into blacklist for disabling adaptive playback feature.

Approval Request Comment
[Feature/Bug causing the regression]:Bug 1317239
[User impact if declined]:Video corruption on Galaxy S4 SPH-L720
[Is this code covered by automated tests?]:No
[Has the fix been verified in Nightly?]:No
[Needs manual test from QE? If yes, steps to reproduce]: Would be helpful. Simply play a video on an affected Galaxy S4 SPH-L720
[List of other uplifts needed for the feature/fix]:None
[Is the change risky?]:No
[Why is the change risky/not risky?]:It only disables a feature that was only recently added on a certain device.
[String changes made/needed]: None
Attachment #8896826 - Flags: approval-mozilla-release?
Attachment #8896826 - Flags: approval-mozilla-beta?
(In reply to kickstand03 from comment #8)
> You're welcome, and thanks for the help. 
> Do I just wait for the next update or does it automatically fix itself? Do I
> need to do anything else?

I think this patch can fix your issue but I'm sorry I don't have this device to verify.

If you can install

https://queue.taskcluster.net/v1/task/RkjSiMRUS5yTCpFiKsMZGw/runs/0/artifacts/public/build/target.apk

This apk has the fix and hope the video can play well on your device.

If it can solve your problem, I've requested uplifting this fix to beta and release channel of firefox.

You don't need to do anything just wait for the app update :)

Thank you.
Flags: needinfo?(jacheng)
Comment on attachment 8896826 [details]
Bug 1390022 - Add Galaxy S4 SPH-L720 model into blacklist for disabling adaptive playback feature.

Taking it as ride along of 55.0.2
Attachment #8896826 - Flags: approval-mozilla-release?
Attachment #8896826 - Flags: approval-mozilla-release+
Attachment #8896826 - Flags: approval-mozilla-beta?
Attachment #8896826 - Flags: approval-mozilla-beta+
Hello James

Just wanted to let you know that I tried the target.apk that you posted and it worked great. Videos are playing normally again. Thank you very much, I like firefox on my android it is so quick and love the addons, glad I didn't have to switch browsers.
https://hg.mozilla.org/mozilla-central/rev/6655fafcd81f
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
(In reply to kickstand03 from comment #14)
> Hello James
> 
> Just wanted to let you know that I tried the target.apk that you posted and
> it worked great. Videos are playing normally again. Thank you very much, I
> like firefox on my android it is so quick and love the addons, glad I didn't
> have to switch browsers.

Glad to hear that it works :)

and thank you for reporting this issue or I have no chance to fix it.
Could not verify this issue on the latest RC (55.0.2)due to the fact that in our studio we don't have the device required.
By any chance, Kickstand03, could you please try and verify this issue on 55.0.2?

Thanks in advance!
Flags: needinfo?(kickstand03)
Hello, just updated and tested 55.0.2 and I can confirm that it is fixed. Videos are playing like normal. You guys are awesome thanks so much!!
Flags: needinfo?(kickstand03)
Thanks for checking it out!
You need to log in before you can comment on or make changes to this bug.