3.33% sessionrestore_many_windows (linux64) regression on push f7e05dffb1ab4e0b9ed46fa2350c3b5fd4b9efe4 (Thu Aug 10 2017)

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression, talos-regression})

53 Branch
perf, regression, talos-regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=2638feb177dd9104a3887fae2ce05931a6b41d6c&tochange=f7e05dffb1ab4e0b9ed46fa2350c3b5fd4b9efe4

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  sessionrestore_many_windows linux64 opt e10s     1,554.50 -> 1,606.33


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8764

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
(Reporter)

Comment 1

a year ago
::dao, this landed recently and I see you authored the patch.  This is on mozilla-beta and I don't see a matching regression on m-c.- is this expected to regression mozilla-beta?
Flags: needinfo?(dao+bmo)
Component: Untriaged → Session Restore
(Reporter)

Comment 2

a year ago
oddly enough, both of these regressions have gone away after seeing this multi-patch commit land on beta:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=7f3005046367008a49b33c00b53eb077451ccca4&tochange=6ea7b3eb8990bb0f7a16119f8545bcf429d88131
Some sessionstore perf impact wouldn't be too surprising and unavoidable for the time being since we had to disable a feature. But I also think sessionrestore_many_windows isn't very reliable.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(dao+bmo)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.