Closed Bug 1390239 Opened 2 years ago Closed 2 years ago

Artifact build of df9beb7 wants to download installers from a 3 day old build

Categories

(Firefox Build System :: General, defect)

57 Branch
defect
Not set

Tracking

(firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: whimboo, Assigned: chmanchester)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I noticed this today because log spam from bug 1388748 was still present for me in my local build on OS X for mozilla-central. From the log it looks like instead of using the current changeset, a 3 day old one was used:

> $ hg up -C central
> 0 files updated, 0 files merged, 0 files removed, 0 files unresolved
> (df9beb7)henrik@whimboo-mac:/data/code/gecko%

So I'm on https://hg.mozilla.org/mozilla-central/rev/df9beb7.

Running `mach build` results in:

> 0:04.61 Attempting to find a pushhead containing 58f678547059f27e2dd930b7c9fa4b7bf44365e2 on mozilla-central.
> 0:04.61 Attempting to find a pushhead containing 58f678547059f27e2dd930b7c9fa4b7bf44365e2 on integration/mozilla-inbound.
> 0:04.62 Attempting to find a pushhead containing 58f678547059f27e2dd930b7c9fa4b7bf44365e2 on releases/mozilla-beta.
> 0:05.70 Retrieving the last 50 pushheads starting with id 93626 on integration/mozilla-inbound
> 0:05.70 Retrieving the last 50 pushheads starting with id 32318 on mozilla-central
> 0:05.75 Installing from remote pushhead 58f678547059f27e2dd930b7c9fa4b7bf44365e2 on integration/mozilla-inbound

This is https://hg.mozilla.org/mozilla-central/rev/58f678547059f27e2dd930b7c9fa4b7bf44365e2 which landed Friday Aug 11th on mozilla-central.

Why was the changeset on mozilla-central not found, and instead inbound used? And then a 3 day old build?

Chris currently have a look into this locally. Thanks.
Flags: needinfo?(cmanchester)
With f31c029 checked out locally I get:

> $ hg log --template '{node}\n' -r 'last(public() and ::., 5)'
> 1b9dac0c4cf374c8fc26bcb432302dfd293098c7
> 31b5a863aee278ac3c39db8d142a7fa98d38797e
> ffc2e43aa834e05f0d51d68dfb36317c1b408b08
> 8be5e7c145999f436c84b181af44838cd28a9efb
> f31c029bbd16cd779f191a63065260aaafad026b

I upgraded Mercurial by end of last week to version:

% hg --version
Mercurial Distributed SCM (version 4.3.1)
I can reproduce this locally, it looks like our mercurial revset to try to find the most recent public changeset isn't giving us what we want. The revset in question is: http://searchfox.org/mozilla-central/rev/6482c8a5fa5c7446e82ef187d1a1faff49e3379e/python/mozbuild/mozbuild/artifacts.py#980

It seems possible there was a change in the mercurial update we need to take into account, I'll take a look.
Assignee: nobody → cmanchester
Flags: needinfo?(cmanchester)
Comment on attachment 8897092 [details]
Bug 1390239 - Accommodate any ordering of "last" revset in artifact builds.

https://reviewboard.mozilla.org/r/168400/#review173638

::: python/mozbuild/mozbuild/artifacts.py:987
(Diff revision 1)
>              self._hg, 'log',
> -            '--template', '{node}\n',
> +            '--template', '{rev}:{node}\n',
>              '-r', 'last(public() and ::., {num})'.format(
>                  num=NUM_REVISIONS_TO_QUERY)
>          ], cwd=self._topsrcdir).splitlines()
> +        return [i.split(':')[-1] for i in reversed(sorted(last_revs))]

Nit: `sorted(last_revs, reverse=True)`.
Attachment #8897092 - Flags: review?(gps) → review+
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/67caba0c3909
Accommodate any ordering of "last" revset in artifact builds. r=gps
https://hg.mozilla.org/mozilla-central/rev/67caba0c3909
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.