Library window should disable most of the 'view' menu because it isn't functional in the library window

RESOLVED DUPLICATE of bug 1402059

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1402059
a year ago
a year ago

People

(Reporter: Atoll, Unassigned)

Tracking

({regression})

unspecified
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox55 unaffected, firefox56 wontfix, firefox57 fix-optional)

Details

(Reporter)

Description

a year ago
On Nightly (2017-08-15) and OS X 10.12.6 (release), the Library window silently ignores any attempt to customize the toolbar using the menu item View -> Toolbars -> Customize...
Hey Tracy, can you attempt to repro and if you can post str. thanks.
Flags: needinfo?(twalker)
Yes, this is easily reproducible.  However, the bug here is that the items under View are visible.  They should all be disabled (greyed out) except the Full Screen option.

STR:

1) open Library from Menu > History > Show all history (Menu > Bookmarks > Show all bookmarks)
2) From the Library, Select Menu > View

Tested results: all items of this menu are visible

Expected results:  All items of this menu should be disabled except the Enter Full Screen option.
Flags: needinfo?(twalker)
Sounds serious, maybe this need to get prioritized into current work. Panos, any thoughts on what to do with this to get it in front of someone?
Component: General → Toolbars and Customization
Flags: needinfo?(past)
Browser Console contains this:

ReferenceError: gBrowser is not defined[Learn More]  browser.js:4373:1
	updateCharacterEncodingMenuState chrome://browser/content/browser.js:4373:1
	onpopupshowing chrome://browser/content/places/places.xul:1:1
ReferenceError: gNavToolbox is not defined[Learn More]  browser.js:5381:7
	getTogglableToolbars chrome://browser/content/browser.js:5381:7
	onViewToolbarsPopupShowing chrome://browser/content/browser.js:5401:22
	onpopupshowing chrome://browser/content/places/places.xul:1:1
ReferenceError: gBrowser is not defined[Learn More]  browser.js:4373:1
	updateCharacterEncodingMenuState chrome://browser/content/browser.js:4373:1
	onpopupshowing chrome://browser/content/places/places.xul:1:1
ReferenceError: gCustomizeMode is not defined[Learn More]  places.xul:1:1
	oncommand chrome://browser/content/places/places.xul:1:1


However this is unlikely to get prioritized for 57 as things stand.
status-firefox57: --- → fix-optional
Flags: needinfo?(past)
Priority: -- → P3

Comment 5

a year ago
This worked OK in 54.
Keywords: regression, regressionwindow-wanted

Updated

a year ago
Summary: Library window silently ignores menu item View -> Toolbars -> Customize... → Library window should disable most of the 'view' menu because it isn't functional in the library window

Comment 6

a year ago
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7ce557b85b611536b69539a7c18d4834ffc92eea&tochange=23d9d005d92afdb5afabeae2ad672323c7d903ad

My bet is bug 1381853. Florian, can you take a look?
Blocks: 1381853
status-firefox55: --- → unaffected
status-firefox56: --- → affected
Flags: needinfo?(florian)

Updated

a year ago
OS: Unspecified → Mac OS X

Updated

a year ago
Keywords: regressionwindow-wanted
status-firefox56: affected → wontfix
(In reply to :Gijs from comment #6)
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=7ce557b85b611536b69539a7c18d4834ffc92eea&tochange=23d9
> d005d92afdb5afabeae2ad672323c7d903ad
> 
> My bet is bug 1381853. Florian, can you take a look?

Too late for 56 at this point, sorry I didn't get to this needinfo soon enough :-/. Mark has a fix for this in bug 1402059 so duping forward.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(florian)
Resolution: --- → DUPLICATE
Duplicate of bug: 1402059
You need to log in before you can comment on or make changes to this bug.