Closed Bug 1390781 Opened 5 years ago Closed 5 years ago

When printing to PDF via Foxit Reader ligatures are missing

Categories

(MailNews Core :: Printing, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: dma_k, Unassigned)

Details

(Whiteboard: [addon:Foxit Reader])

Attachments

(2 files)

994 bytes, text/plain
Details
53.50 KB, text/pdf
Details
Attached file test.eml
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160420142932

Steps to reproduce:

It seems like the issue happens for the combination of Thunderbird v45.8.0 + Foxit Reader (https://www.foxitsoftware.com/downloads/), however I ask the community who is expert in printing and PDF to help with the issue.

Steps to reproduce:
* Open attached test.eml via File → Open Saved Message...
* Press Ctrl-P and print this message to special PDF printer, provided by Foxit Reader (Foxit Reader PDF Printer).

The original text:

  office effort efficient face
  offer foot

is displayed as the following in PDF (see attached test.pdf):

  o ce e ort e cient face
  o er foot

In other words all ligatures like "ff", "fi" are gone.

Additional information:
* If I print to real printer from Thunderbird, everything is fine.
* If I extract HTML from message and print it to PDF from Firefox, everything is fine.
Attached file test.pdf
version 45 is no longer supported. 
Can  you reproduce this with version 52?
Component: Untriaged → Printing
Flags: needinfo?(dma_k)
Product: Thunderbird → MailNews Core
Version: 45 Branch → 45
Attachment #8897778 - Attachment mime type: message/rfc822 → text/plain
There aren't even any ligatures. Maybe the printer driver will turn the "ff" into a ligature, but in the data you have two "f" characters.

So

<html>
  <head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    office effort efficient face<br>
    <font size="3">offer foot</font>
  </body>
</html>

prints OK with Foxit when put into a HTML document and opened in Firefox.

We really have no expertise in this area, printing is handled using Mozilla core software. So if it prints in FF it should print in TB.
I was testing with the same version of FoxitReader (7.3.0.118). It is not recent one, anyway here are the results:

Working Thunderbird versions:
38.3.0
45.0
45.3.0
45.6.0
52.3.0 (latest Thunderbird)

Not working versions:
45.7.0
45.7.1
45.8.0 (originally reported)

From above the problem is fixed in latest Thunderbird version. It was introduced in 45.7.0. Unfortunately I have to stick to 45.x branch because of broken extension backward compatibility.
Flags: needinfo?(dma_k)
Thanks for testing it.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
TB 45 is at the end of its lifetime and doesn't receive any fixes. Which add-on isn't working?
It seems like I was wrong with my testing report above as I was testing on different environments, so please invalidate my post. All versions from 38.3.0 till 52.3.0 work fine. The problem was found in FoxitReader versions 7.0, 7.3 and 8.0 (see http://forums.foxitsoftware.com/forum/portable-document-format-pdf-tools/foxit-reader/164995-when-printing-to-foxit-reader-pdf-printer-from-thunderbird-ligatures-are-gone) and was fixed in FoxitReader 8.2.0.2051 (at least I could not reproduce it).

Concerning the addons + Thunderbird 52.x:
Addons Enigmail v1.8.2 and Sieve v0.2.3h have stopped working. It turned out that Sieve v0.2.3k that works on 52.x could be downloaded from GitHub but was not pulled to official addon repository hence was not updated automatically and require manual installation. Latest Enigmail versions (1.9.x) that are fixed to work on 52.x require GnuPG 2.x, thus require chained upgrade. Bottomline: there are no real stoppers to upgrade to Thunderbird 52.x/53.x, it just requires some time to do above mentioned chained upgrades.
Resolution: WORKSFORME → INVALID
Whiteboard: [addon:Foxit Reader]
You need to log in before you can comment on or make changes to this bug.