Expand the /provisioners/:provisionerId/worker-types endpoint to return metadata

RESOLVED FIXED

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: hassan, Assigned: hassan)

Tracking

Details

(Assignee)

Description

a year ago
Presently, the /provisioners endpoint returns a list of provisionerIds. It needs to be expanded to return metadata:

GET /v1/provisioners/:provisionerId/worker-types/
signature: workerTypes(provisionerId, {continuation})
scopes:    -
response: {
  workerTypes: [
    {
      provisionerId:  '...',
      workerType:     '...',
      expires:        '...',
      description:    '...',
      documentation:  '...',
      payloadSchema:  {...},
      stability:      'experimental|stable|deprecated',
    },
    ...
  ],
  continuation: '...',  // optional contiunation token
}
(Assignee)

Updated

a year ago
Duplicate of this bug: 1388801
(Assignee)

Updated

a year ago
Assignee: nobody → helfi92

Comment 2

a year ago
Commit pushed to master at https://github.com/taskcluster/taskcluster-queue

https://github.com/taskcluster/taskcluster-queue/commit/69e245968cbce879d2263d462fd6d8b77a4eabc4
Merge pull request #187 from helfi92/expand-workertypes

Bug 1390867 - Expand the worker-types endpoint to return metadata
(Assignee)

Comment 3

a year ago
payloadSchema and documentation was omitted in the final commit because it was not really clear where we wanted to store that data. We will tackle this issue later.
(Assignee)

Updated

a year ago
Blocks: 1394809
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.