Closed Bug 1390964 Opened 4 years ago Closed 4 years ago

Cannot run mochitests if Firefox is built with a gcc that's not installed in the default prefix

Categories

(Testing :: Mochitest, defect)

Version 3
x86_64
Linux
defect
Not set
normal

Tracking

(firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: botond, Assigned: botond)

Details

Attachments

(1 file)

STR:
  1. Build gcc from source, and install it into a non-default prefix
     (that, is something other than '/usr').
  2. Build Firefox with the newly built gcc.
  3. Try to run a mochitest with |mach mochitest|.

Expected results:
  The mochitest runs.

Actual results:
  The mochitest run fails with errors of the form:

  <objdir>/dist/bin/xpcshell: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found

The problem is that programs built with such a gcc are linked to a libstdc++.so that's not in the linker's default search path, so the path containing the libstdc++.so needs to be added to LD_LIBRARY_PATH. However, the mochitest harness clobbers LD_LIBRARY_PATH [1].

[1] http://searchfox.org/mozilla-central/rev/13148faaa91a1c823a7d68563d9995480e714979/testing/mochitest/runtests.py#420
Comment on attachment 8897931 [details]
Bug 1390964 - Do not clobber an existing LD_LIBRARY_PATH in the mochitest harness.

https://reviewboard.mozilla.org/r/169214/#review178706
Attachment #8897931 - Flags: review?(ted) → review+
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa04de352d99
Do not clobber an existing LD_LIBRARY_PATH in the mochitest harness. r=ted
Flags: needinfo?(botond)
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e7d48fa2052
Do not clobber an existing LD_LIBRARY_PATH in the mochitest harness. r=ted
https://hg.mozilla.org/mozilla-central/rev/6e7d48fa2052
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.