Closed Bug 139110 Opened 22 years ago Closed 22 years ago

Final page in browser fails to print

Categories

(Core :: Printing: Output, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: throop, Assigned: rods)

References

()

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

This web page is a simple text+graphics page.  When I print it, only the first
page (of two) gets printed -- the second page just never shows up. 
Interestingly, by looking at the mozilla.ps file in ghostscript, code to print
both pages is in fact there, but for some reason, the second page never comes
out of the printer.

I've seen this on many other pages too, but this is the simplest reproducible case.

Printer is an HP 4550DN, jet-direct.

Reproducible: Always
Steps to Reproduce:
1.Go to page
2.Hit 'Print'

Actual Results:  Prints first page only ('1 of 2' on footer, and text of web
page is truncated).

Expected Results:  Should print two pages.

Might (??) be related to bug 125144, as that also deals with text that is in the
.ps file, but never gets printed on an HP laserjet.  However, this bug is
different, in that the printer gives no error message, and the document prints
before just truncating the job.
wfm 2002042023 on linux (on a HP 5Si and CUPS)

Henry:
When xghostview shows both pages, it's not mozillas fault..

Does it work, when you send the PS file via lpr ?
(lpr mozilla.ps)

Your PS File works fine on the printer here.. and also GV has no problem ..
Henry: do you also see the problem in Print preview?

(at least there it works for me - on Linux, 1.0RC1)
Print Preview works fine and shows both pages.

gv works and shows both pages.

I get the same results whether I print directly from Mozilla or do it with lpr.

It appears that there may be some sort of incompatability between Mozilla's .ps
output and some HP printers -- see bug 125144 for another instance of this.  In
both this bug and this one, although gv properly shows the page, they fail to
print properly.  This is a new, off-the-shelf, HP Postscript printer which works
with every .ps file that's ever been sent to it, with the exception of some
Mozilla output.

(For what it's worth, this mozilla.ps fails to print at all on an HP LJ 5M -- an
example of 125144.)
Reporter:
Can you print the following postscript jobs without problems ?
- attachment 79117 [details] (300DPI, ISO A4)
  OR
- attachment 79118 [details] (600DPI, ISO A4)
Both attachments print fine on both the printers I've tried on.  No missing pages.
Both PostScript jobs were from the Xprint module, therefore I guess something is
wrong with Mozilla's PostScript module... ;-(

Workaround for this bug:
Read
http://puck.informatik.med.uni-giessen.de/people/gisburn/work/xprint/quickguide_koi8_r.txt
(this is for cyrillic KOI8-R but the same procedure applies to other languages,
too (you only need matching fonts for your language:)) ...
Henry, thats also a try worth:

Try to start mozilla with:

mozilla -profilemanager

and create a new (test)-profile ..

Once i had a problem that mozilla did create _very wrong_ PS files (GV crashed,
my printer also :) ).. Mozilla had a problem with the 'old' configstuff in my
.mozilla dir..
I just tried making a new profile and printing from there.  Same results as
before -- the second page is not printed.  I haven't tried using xprint.
I'm seeing the same thing as well on an HP Laser 4 Plus.  All pages beyond the 
first are not printed.  Interestingly, I've seen the similar behavior with ths 
printer when trying to print an outsize image that does not fit on a single 
page.  So, I am not convinced this is necessarily moz specific.

I suspect, not being a printer expert, that many applications send data to the 
printer assuming that the printer will insert page breaks when appropriate, but 
this model of printer does not insert page breaks of its own accord. 
I've attempted to force mozilla to insert page breaks itself by inserting a 
@page directive:
@page {size: 8.5in 11in}

Any comments/suggestions?
The @page work isn't checked in yet. The page prints fine for me to a file.
rods wrote:
> The page prints fine for me to a file.

I assume that the PostScript output of the PostScript module does not work on
all HP printers correctly.
Confirming per comments in this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I just tried this with a fairly recent build and it works now on Linux
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WORKSFORME
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.