Closed Bug 1391160 Opened 3 years ago Closed 3 years ago

(photon) Status bar icons are invisible after back from fullscreen mode

Categories

(Firefox for Android :: General, defect)

Unspecified
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- verified

People

(Reporter: jwu, Assigned: jwu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [FNC][SPT57.3][MVP])

Attachments

(2 files)

Steps to reproduce:
1. Use Nightly to browse "https://davidwalsh.name/demo/fullscreen.php".
2. Press "Launch Fullscreen", the status bar is hidden.
3. Press "Hide Fullscreen", the status bar is shown again.

Expected result:
The icons in status bar are visible as usual.

Actual result:
The icons in status bar become invisible.
Comment on attachment 8898154 [details]
Bug 1391160 - Remember SYSTEM_UI_FLAG_LIGHT_STATUS_BAR when show/hide fullscreen.

https://reviewboard.mozilla.org/r/169514/#review174846
Attachment #8898154 - Flags: review?(cnevinchen) → review+
Comment on attachment 8898154 [details]
Bug 1391160 - Remember SYSTEM_UI_FLAG_LIGHT_STATUS_BAR when show/hide fullscreen.

https://reviewboard.mozilla.org/r/169514/#review175302
Attachment #8898154 - Flags: review?(walkingice0204) → review+
Comment on attachment 8898154 [details]
Bug 1391160 - Remember SYSTEM_UI_FLAG_LIGHT_STATUS_BAR when show/hide fullscreen.

https://reviewboard.mozilla.org/r/169514/#review175856

::: mobile/android/geckoview/src/main/java/org/mozilla/gecko/util/ActivityUtils.java:42
(Diff revision 1)
>                  }
>              } else {
>                  newVis = View.SYSTEM_UI_FLAG_VISIBLE;
>              }
>  
> +            if (Build.VERSION.SDK_INT >= 23) {

See constants in AppConstants.
Attachment #8898154 - Flags: review?(s.kaspari) → review+
Just for reference, I use link https://davidwalsh.name/demo/fullscreen.php to test fullscreen show/hide.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/21cb52d98f1c
Remember SYSTEM_UI_FLAG_LIGHT_STATUS_BAR when show/hide fullscreen. r=nechen,sebastian,walkingice
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/21cb52d98f1c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Still reproducing on Nightly 57 (2017-08-25).
Devices:
Oneplus Two (Android 6.0.1)
Motorola Nexus 6 (Android 7.0)
Whiteboard: [FNC][SPT57.2][INT]
Looks like our code has been mis-merged because bug 1126479 was also editing 'ActivityUtils.java' at same time. We would send another patch to fix this issue later.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [FNC][SPT57.2][INT]
Pushed by topwu.tw@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ed62367e3c70
Remember SYSTEM_UI_FLAG_LIGHT_STATUS_BAR when show/hide fullscreen. r=nechen,sebastian,walkingice
Whiteboard: [FNC][SPT57.3][MVP]
https://hg.mozilla.org/mozilla-central/rev/ed62367e3c70
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Verified as fixed on Nightly 57 (2017-08-30).
Devices:
Oneplus Two (Android 6.0.1)
HTC Desire 820 (Android 6.0.1)
Google Pixel (Android 7.1.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.