Status

enhancement
P5
normal
REOPENED
2 years ago
6 months ago

People

(Reporter: kirillstyopkin, Unassigned)

Tracking

55 Branch

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36

Steps to reproduce:

I create firefox extension, and browser.tabCapture.capture method doesn't exist while chrome.tabCapture.capture exists


Actual results:

browser.tabCapture.capture never resolves


Expected results:

browser.tabCapture.capture should work like chrome.tabCapture.capture, or could you please give me some alternative method for getting mediastream from current tab sounds
Component: Untriaged → WebExtensions: Compatibility
Product: Firefox → Toolkit
Summary: browser.tabCapture.capture method doesn't exist while chrome.tabCapture.capture exists → Implement tabCapture API
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1261339

Comment 2

2 years ago
Hi guys! I have have been working on the same problem 2 month already. We adopt Chrome extension functionality to FF Add-on. And we have a problem with tabCapture. Any plans to realize this feature in nearest future?

Comment 3

2 years ago
I think tabCapture and pageCapture are two different things, although they sound quite similar. 

https://developer.chrome.com/extensions/tabCapture > Use the chrome.tabCapture API to interact with tab media streams. 

https://developer.chrome.com/extensions/pageCapture > Use the chrome.pageCapture API to save a tab as MHTML.

Comment 4

2 years ago
Yep! Thank you! We do know this difference, but the problem is that that tabCapture is not implemented in Firefox

Comment 5

2 years ago
Sorry, my comment was directed to zombie who marked this as a duplicate.
Flags: needinfo?(tomica)
Huh, sorry I jumped too quick on the duplicate button.

(another excellent naming job by the Chrome team)
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(tomica)
Resolution: DUPLICATE → ---

Updated

2 years ago
Priority: -- → P5

Comment 7

2 years ago
Do you plan to implement https://developer.chrome.com/extensions/tabCapture#method-captureOffscreenTab ? It is experimental in Chrome, but our legacy Firefox extension heavily relies on this feature (make previews of websites in "background"), so we can't really move it to WebExt without loosing functional.
Duplicate of this bug: 1443484
I'll note in passing that this is more or less already implemented on the platform side.

Comment 10

a year ago
Our extension is also depending on this API. We use it to manage the currently playing video/audio on each tab. Does anyone know if there is any alternatives?

Updated

11 months ago
Product: Toolkit → WebExtensions

Comment 11

6 months ago
+1 for this feature
You need to log in before you can comment on or make changes to this bug.