Closed Bug 1391607 Opened 5 years ago Closed 5 years ago

Crash in IPCError-browser | ShutDownKill

Categories

(Firefox :: General, defect)

55 Branch
Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- wontfix
firefox56 --- unaffected

People

(Reporter: boaz.dodin, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, regressionwindow-wanted)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-05e2d303-774c-4297-8f4b-8e16d0170818.
=============================================================

Since an update to Firefox 55, several times a general hang was experienced and later a crash.
Pretty sure it's a regression from v54.

Additional crash reports:
ID: 124dbf00-9f5b-423f-b1c8-7c4a00170818
ID: efdb2a84-1f49-4849-af4c-34ffc0170818
And an additional crash report:
ID: 205944bb-bb70-476d-9233-8fceb0170818
It's generic hang, and per no STR & regression range, I'm duping this bug to bug #1279293.
Status: NEW → RESOLVED
Crash Signature: [@ IPCError-browser | ShutDownKill]
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: IPCError_ShutDownKill
The regression range is between the 54 and 55 releases.
STR:
1. About 20-25 open tabs
2. After some time the browser content can't be used (although the interface is alive)
3. Closing Firefox
4. Trying to reopen - it still not closed
5. Killing the Firefox process via KSysGuard

Additional reports:
ID: 2327071d-a7c1-4eab-b626-6ad980170822
ID: e3d7c11e-c124-43a1-b86c-dca250170822

This is probably the worse bug I ever had for years on Firefox.
I will be more than happy to pinpoint it, please do not just dup it.
Status: RESOLVED → REOPENED
Flags: needinfo?(Virtual)
Resolution: DUPLICATE → ---
Thanks.

If you will have time for this, you can pinpoint the specific regression range, by using the mozregression GUI ( https://github.com/mozilla/mozregression/releases ).
Info how to use it - http://mozilla.github.io/mozregression/quickstart.html
Status: REOPENED → NEW
Has Regression Range: --- → no
Has STR: --- → yes
Flags: needinfo?(Virtual)
I am on Linux (Kubuntu), production PC, release channel - as per 55 notes "Firefox does not support downgrades, even though this may have worked in past versions. Users who install Firefox 55+ and later downgrade to an earlier version may experience issues with Firefox."
It looks like mozregression is not an option for me...
Flags: needinfo?(Virtual)
It uses its own new profile by default.
Flags: needinfo?(Virtual)
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #6)
> It uses its own new profile by default.

Additionally, you can set it up to clone your existing profile and reuse a new copy of that for each iteration.
Flags: needinfo?(boaz.dodin)
We are investigating this, but will not hold a release until we find a fix for it.
Thanks; unfortunately, basically every restart ends with this type of crash: https://crash-stats.mozilla.com/report/index/1e4d40ff-ed9a-4136-bce4-1c8f80170830

As a result, my YouTube videos and any almost other stuff I was doing at the time are unable to save the context, which is annoying. (Besides, F55 becomes too slow and start to render pages choppingly too quickly, which was the reason for me to restart it and get this crash.)
To avoid this issue, for about 10 days I am on Firefox 56 beta (via the firefox-next PPA).
So far - no crashes at all.
Flags: needinfo?(boaz.dodin)
(In reply to Boaz Dodin from comment #10)
> To avoid this issue, for about 10 days I am on Firefox 56 beta (via the
> firefox-next PPA).
> So far - no crashes at all.

If it's fixed in 56, there's likely nothing we can really do here anymore. It's too late to spin a dot release, and 56 will be released in about 2 weeks' time. So I guess I'll close the issue. If we do find out what caused it / fixed it, that'd be helpful, but hey, if it works... :-)
Status: NEW → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.