JSOP_IN often not optimized on Speedometer's Elm benchmark

RESOLVED DUPLICATE of bug 1357759

Status

()

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1357759
2 years ago
2 years ago

People

(Reporter: jandem, Assigned: tcampbell)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
We make a ton of calls to IonInIC::update and OperatorIn on the Elm benchmark.

I didn't investigate why, but I'm pretty sure we need a megamorphic stub for this (we have one for JSOP_HASOWN but not JSOP_IN).
(Reporter)

Comment 1

2 years ago
(Still hard to believe we didn't even have an Ion IC for this until bug 1337773, Firefox 55 :)
(Assignee)

Updated

2 years ago
Depends on: 1361731
(Assignee)

Updated

2 years ago
Priority: -- → P3
(Assignee)

Updated

2 years ago
Assignee: nobody → tcampbell
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Looks like it was actually missing proxy support. Patches on Bug 1357759 seem to fix all remaining failed ICs in firefox startup + speedometer except for things with Resolve hooks (XPCComponents_Interfaces, XPCWrappedNative_NoHelper, and ArgumentsObjects).
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357759
You need to log in before you can comment on or make changes to this bug.