Send an event when the user saves an image

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
8 months ago
8 months ago

People

(Reporter: SimonB, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
All
iOS

Firefox Tracking Flags

(fxios8.3, fxios-v8.3 verified, fxios-v9.0 affected, fxios-v10.0 verified)

Details

(Whiteboard: [mma] [MobileCore])

Attachments

(1 attachment, 1 obsolete attachment)

55 bytes, text/x-github-pull-request
justindarc
: review+
Details | Review | Splinter Review
(Reporter)

Description

8 months ago
Build: 918e20ecd
Device: iPad Air 2
iOS: 10.3.3

Steps to reproduce:
1. Go to images.google.com and search for 'images'
2. Long tap on a picture
3. From the context menu, tap on save
4. Check the Leanplum dashboard

Actual result:
- The event "E_Download_Media_Saved_Image" is not triggered.

Expected results;
- The "E_Download_Media_Saved_Image" should be triggered when saving a image to iOS device.

Updated

8 months ago
Assignee: nobody → bmunar
Whiteboard: [MMA] → [mma] [MobileCore][needsuplift]

Updated

8 months ago
tracking-fxios: ? → 9.0
Yup, put it in the wrong place, I think this case is when the user has already allowed Firefox permission to access their photo gallery. I just put it to record when a user FIRST saves an image. My bad!!
Created attachment 8899611 [details] [review]
PR
Attachment #8899611 - Flags: review?(sarentz)

Updated

8 months ago
tracking-fxios: 9.0 → 8.3

Updated

8 months ago
Attachment #8899611 - Flags: review?(sarentz) → review-

Updated

8 months ago
Summary: "E_Download_Media_Saved_Image" is not triggered when saving a picture to iOS → Send an event when the user saves an image to their album

Updated

8 months ago
Summary: Send an event when the user saves an image to their album → Send an event when the user saves an image
Created attachment 8901221 [details] [review]
PR https://github.com/mozilla-mobile/firefox-ios/pull/3094

This patch sends an event when the user succesfully saves an image to their photo album. Contrary to the previous code, this patch only sends the event when the save was succesfull. If it failed with a real error, of if it failed because the user denied the request, the event will not be sent.
Attachment #8899611 - Attachment is obsolete: true
Attachment #8901221 - Flags: review?(jhugman)

Updated

8 months ago
Assignee: bmunar → nobody
Landed on master, uplifted to v8.x and v9.x

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED

Updated

8 months ago
Whiteboard: [mma] [MobileCore][needsuplift] → [mma] [MobileCore]
(Reporter)

Comment 6

8 months ago
Verifying as fix on master b06b848a9f74.
status-fxios-v10.0: --- → verified
(Reporter)

Comment 7

8 months ago
Verifying as fix on beta 8.3(5817).
Status: RESOLVED → VERIFIED
status-fxios-v8.3: --- → verified
You need to log in before you can comment on or make changes to this bug.