If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pass the full event or at least event.shiftKey to the callback in toolkit/content/widgets/notification.xml

RESOLVED DUPLICATE of bug 1392055

Status

()

Core
XP Toolkit/Widgets: XUL
RESOLVED DUPLICATE of bug 1392055
a month ago
a month ago

People

(Reporter: Jorg K (GMT+2), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
At
https://dxr.mozilla.org/mozilla-central/rev/833f84d0d5c729054a3aa8b3f34735f56fe6436b/toolkit/content/widgets/notification.xml#491
var result = callback(this, button, aEvent.target);

we call a button callback with the event target. It would be beneficial to pass the full event, or at least aEvent.shiftKey.

So the patch would be a one liner adding the extra argument.

Sorry about the NI SPAM, I really can't see who's in charge of this. Please point me to the right person and also adjust the component of this bug.
(Reporter)

Comment 1

a month ago
Hmm, something funny happened and I created three bugs instead of one.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1392055
You need to log in before you can comment on or make changes to this bug.