Closed Bug 1392269 Opened 4 years ago Closed 2 years ago

Image upload should clear cache immediately

Categories

(Websites :: wiki.mozilla.org, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mkaply, Assigned: spike)

Details

I uploaded a new version of this image:

https://wiki.mozilla.org/File:ReportSiteNightlyIcon.png

The list of files shows the new image in the thumbnail:

https://wiki.mozilla.org/Special:ListFiles

but it didn't actually replace the existing image.

And when I try to upload the image as a new image, it says the image already exists.
It looks like it was a caching issue. It's fixed now.

so the bug is that when you upload a replacement, it should replace immediately.
Summary: Image upload didn't actually replace the image → Image upload should clear cache immediately
Assignee: nobody → spike

Did you mean to remove the CCs from this bug?

(In reply to Mike Kaply [:mkaply] from comment #2)

Did you mean to remove the CCs from this bug?

I think so - I don't think that there was anybody there that would be interested.

Am in the process of doing a few tests to see if the problem you have had has gone away - can hopefully close it in next few days.

Spike

From the test that I have recently done, this seems to be working as expected, although it did take 30-secs or so for the new thumbnail images to be generated and the 'new' image to be displayed.

Am going to close this bug but will repeat tests when we have updated the MediaWiki base software.

Spike

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.