When restoring a tab at startup, Firefox loads and paints about:newtab before it loads the restored tab.

RESOLVED DUPLICATE of bug 1054740

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 1054740
10 months ago
10 months ago

People

(Reporter: atoll, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf][photon-perf][triage])

When I restarted Nightly (2017-08-21) on OS X 10.12.6, I noticed that the one tab I had open first painted about:newtab, complete with top left "animal" icon, and *then* reloaded the tab I had open before I quit Firefox.

Shouldn't that repaint be avoided in the 'restore tabs' scenario? Seems unnecessary to load up and paint the DOM for about:newtab only to throw it away milliseconds later.

Updated

10 months ago
Component: General → Session Restore
See Also: → bug 1379587
Whiteboard: [qf][photon-perf][triage]
Are you sure it loads about:newtab and not about:home? If it's about:home, this is a duplicate of bug 1054740.
It loads a fox icon, but I can't see fast enough beyond that. Feel free to dupe as "probably dupe", and if we fix bug 1054740 someday, I'll QA it under the theory of "probably fixed".

Comment 3

10 months ago
(In reply to Richard Soderberg  [:atoll] from comment #2)
> It loads a fox icon, but I can't see fast enough beyond that. Feel free to
> dupe as "probably dupe", and if we fix bug 1054740 someday, I'll QA it under
> the theory of "probably fixed".

That bug actually got fixed and then backed out because it regressed some other stuff, and is on its way to being fixed again. "just not loading about:home" is harder than it sounds, it turns out.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1054740
Heh. If only we could local-scope the default home page from the tab's perspective to be the URL being restored into the tab, everything would be simple =)
You need to log in before you can comment on or make changes to this bug.