Clicking on Mozilla icon in Dock does not open minimized windows

VERIFIED DUPLICATE of bug 90823

Status

VERIFIED DUPLICATE of bug 90823
17 years ago
14 years ago

People

(Reporter: cblackst, Assigned: Matti)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In most OS X Apps (Mail, IE, Office v.X, Yahoo Messenger, etc), if you have
minimized a window and have no other windows active, when you click on the Dock
icon for that app, the most recently minimized window is maximized (opened).
Mozilla does not do this.

From Apple Aqua Human Interface Guidelines -> The Dock -> Clicking in the Dock

"When a user clicks an open application's icon in the Dock, the application
becomes active and all open unminimized windows are brought to the front;
minimized document windows remain in the Dock. 

*** If there are no unminimized windows when the user clicks the Dock icon, the
last minimized window should be expanded and made active. *** 

If no documents are open, the application should open a new window. (If your
application is not document based, display the application's main window.)"

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 90823 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.