Calling the window.crypto.SignText() method in JavaScript

VERIFIED DUPLICATE of bug 29152

Status

P2
enhancement
VERIFIED DUPLICATE of bug 29152
17 years ago
2 years ago

People

(Reporter: nraya, Assigned: kaie)

Tracking

1.0 Branch
Future
Bug Flags:
blocking1.4a -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Calling the window.crypto.SignText() method in JavaScript in Netscape 4.7x for 
client-side signing of documents works.
 When used in 6.2 the same function , returns the following error message -
 
  Error: uncaught exception: [Exception... "Component returned failure 
 code:
  0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOMCrypto.signText]"  nsresult:
  "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame ::
  :: ff :: line 8"  data: no]
  
  How do we use this function in version 6.2? If this function is no longer 
available, has it been replaced with another one that achieves the same result ? 

The following is a sample script,
******************************************************************************

<html>
 <head>

 <script language=Javascript1.2>


 function signTextForm() {

 window.crypto.signText(document.test.signText.value,"ask");
 return true;

 }


 </script>
 </head>

 <body>

 <form name="test">

 <input type="text" name="signText" value="Sign this text">

 <input type="button" name="signButton" value="Sign this text" 
 onClick="signTextForm();">

 </form>

 </body>
 </html>

 Error: uncaught exception: [Exception... "Component returned failure code: 
 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOMCrypto.signText]"  nsresult: 
 "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: 
 file:///C|/WINNT/Profiles/nraya/Desktop/sign.html :: signTextForm :: line 
 8"  data: no]
 Error: document.ticktext has no properties
 Source File: https://lizard/
 Line: 39
(Reporter)

Updated

17 years ago
Keywords: nsenterprise

Comment 1

17 years ago
Browser, not engine. Reassigning to Security:General -
Assignee: dbradley → mstoltz
Component: XPConnect → Security: General
QA Contact: pschwartau → bsharma
->PSM. Do we still have crypto APIs in JS?
Assignee: mstoltz → ssaux
Component: Security: General → S/MIME
Product: Browser → PSM
QA Contact: bsharma → carosendahl
Version: other → 2.3

Comment 3

17 years ago
I am actually seeing these errors on Linux, not Windows.

I have several scripts that I am debugging at the moment to understand the
cause.  However the fact that several scripts work without problem on the
Windows platform yet return the error mentioned within this defect leaves the
door open for further investigation.

Updated

17 years ago
Severity: major → enhancement
Component: S/MIME → Client Library
Priority: -- → P2
Target Milestone: --- → Future

Comment 4

17 years ago
This function is not available in PSM.
This is a future enhancement.

Comment 5

17 years ago
shouldn't 4xp keyword be added here?

Updated

17 years ago
Keywords: 4xp

Comment 6

17 years ago
Kai, we talked about this.
Assignee: ssaux → kaie

Updated

17 years ago
Blocks: 92997

Comment 7

17 years ago
How is this crypto thing now? And why it is NOT_IMPLEMENTED?
I would use this, and must realize, that won't work under mozilla based browsers :(
Thx.

Comment 9

17 years ago
Thx! So in the future ... :(

Comment 10

16 years ago
is there chance for a fix by 1.3?

Comment 11

16 years ago
is this currently blocking my clients signed s/mime webmail for mozilla. damn..

Updated

16 years ago
Flags: blocking1.4a?

Updated

16 years ago
Flags: blocking1.4a? → blocking1.4a-

Comment 12

16 years ago
is this a duplicate of bug 29152? This bug even has a patch...
I'm sorry I couldn't find it earlier.

There is a solution to this problem from Lfern  (http://secclab.mozdev.org) or
(http://www.sourceforge.net/projects/formx/). It would be good if these could be
integrated into Mozilla, so that no downloading of XPI package would be needed.
(Assignee)

Comment 13

16 years ago
I agree it's a duplicate.

*** This bug has been marked as a duplicate of 29152 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 14

16 years ago
v
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

16 years ago
> is this currently blocking my clients signed s/mime webmail for mozilla.

Henrik, I don't understand. Could you elaborate why you need this?
If you add comments, please add to bug 29152. Thanks!

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

11 years ago
Version: psm2.3 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.