Open Bug 1392673 Opened 3 years ago Updated 1 year ago

Black flicker/blink/flash before drop down menu rendering after landing patch from bug #1382680

Categories

(Core :: Graphics, defect, P3, major)

56 Branch
x86_64
Windows 7
defect

Tracking

()

Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox55 --- unaffected
firefox56 - wontfix
firefox57 - wontfix
firefox58 --- wontfix
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix

People

(Reporter: Virtual, Unassigned)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [gfx-noted])

Attachments

(2 files)

STR:
1. Open drop down menu with mouse button
and enjoy black flicker/blink/flash before drop down menu rendering.

If you can't reproduce it first time,
just spammy press mouse button multiple times to reproduce it instantaneously.


Regression range pushlog:
https://hg.mozilla.org/integration/autoland/json-pushes?changeset=62ab9018744dbf57f811ee26fac14542be5e02ee&full=1


Caused by:
Bug #1382680 - Only add extended style WS_EX_COMPOSITED when using OMTC, r=bas,jimm
Flags: needinfo?(howareyou322)
Has Regression Range: --- → yes
Has STR: --- → yes
Summary: Black flicker/blink/flash before drop down menu rendering → Black flicker/blink/flash before drop down menu rendering after landing patch from bug #1382680
I can't reproduce this on my windows 7 machine. Reporter, could you attach the video when the problem happened?
Flags: needinfo?(howareyou322) → needinfo?(Virtual)
Unfortunately, the issue, which is this black flicker/blink/flash is not seen on attached screencast.

STR:
1. Open this URL - http://forums.mozillazine.org/viewforum.php?f=23
2. Open drop down menu with mouse button
and enjoy black flicker/blink/flash before drop down menu rendering.

I'm attaching also Graphics section from about:support (WebGL is disabled manually).
Per bug #1382680 comment #31, I'm marking Firefox 56 as also affected.
Version: 57 Branch → 56 Branch
Reporter, I can't see the black flicker from attachment 8900164 [details] and I only saw the menu keeping disappear/appear. I think it is normal to see pop up menu disappear/appear when you click the mouse button in different place in old or current nightly.

And I can't reproduce the black flicker from comment 3. Can you attach the video about the good behavior?
Flags: needinfo?(Virtual)
(In reply to Peter Chang[:pchang] from comment #5)
> Reporter, I can't see the black flicker from attachment 8900164 [details]
> and I only saw the menu keeping disappear/appear.

I wrote that, unfortunately it's not visible on screencast,
see:
(In reply to Virtual_ManPL [:Virtual] from comment #3)
> Unfortunately, the issue, which is this black flicker/blink/flash is not
> seen on attached screencast.



(In reply to Peter Chang[:pchang] from comment #5)
> And I can't reproduce the black flicker from comment 3. Can you attach the
> video about the good behavior?

I will record screencast with phone camera at 120FPS, so it will be probably visible.
> (In reply to Peter Chang[:pchang] from comment #5)
> > And I can't reproduce the black flicker from comment 3. Can you attach the
> > video about the good behavior?
> 
> I will record screencast with phone camera at 120FPS, so it will be probably
> visible.

Done, see it under this URL - https://a.pomfe.co/mwebexk.mp4
It's reproducible in about 25% in all drop down menu renderings.
Flags: needinfo?(howareyou322)
[Tracking Requested - why for this release]: Regression
I still couldn't reproduce this in another window 7 machines (nv 630). Reporter, are you able to reproduce this in another windows 7 environment? It might be related to hardware.
Flags: needinfo?(howareyou322) → needinfo?(Virtual)
This seems to be an edge case behavior. Track 56- and mark 56 as fix-optional. Feel free to nominate again if you don't disagree.
(In reply to Peter Chang[:pchang] from comment #9)
> I still couldn't reproduce this in another window 7 machines (nv 630).
> Reporter, are you able to reproduce this in another windows 7 environment?
> It might be related to hardware.

I will try and report back with results.

Edge case to very fast reproducing this issue is:
STR:
1. Enable "Menu Bar"
2. Press "File" option to open File menu
3. Move mouse cursor/pointer right and left between "Help" option and "File" option.



@ Alice0775 White - As senior bugmaster, are you able to reproduce this issue on Windows 7?
Flags: needinfo?(alice0775)
My Win7 is on VM and HWA is not available. So, I cannot test this.
Flags: needinfo?(alice0775)
It happening also here in Safe Mode without HW.
Flags: needinfo?(Virtual)
It may need the following information.
Windows System Theme, 
Information of "Performance of Visual Effects"
In my case, I'm using default "Windows 7" Aero composition (only window color was changed to black) and "Performance of Visual Effects" is set to "Custom:" with all options marked/checked/enabled.
Peter, can we get a try build with bug 1382680 patches backed out to confirm the regression range?  Then we could perhaps get :Virtual to run it and verify.
Flags: needinfo?(howareyou322)
Priority: -- → P2
FYI - I was running mozregression GUI and it specified that it was caused by bug #1382680, see pushlog from comment #0. But I can resest by double checking it in new build to make sure, that it's really caused by it.
Reporter, I made some changes with the latest master(not backed out bug 1382680). Could you try to reproduce the problem with the following try build? Thanks.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=880b0cc739bc58e0aa56b5900574353657b255ce
Flags: needinfo?(howareyou322) → needinfo?(Virtual)
Hmm, seems I didn't used Treeharder for very long time, as I can't find URL with download ZIP file.
Is it this "target.zip" in "Job Details" tab, when I'm pressing "B" on "Windows 2012 x64 opt"?
I remember that it had proper name, not some odd one, like now.
Flags: needinfo?(howareyou322)
After clicking one build task, you can search for "artifact uploaded: target.zip" and download the target.zip.
Flags: needinfo?(howareyou322)
I can still reproduce issue with this build (rev: 880b0cc739bc58e0aa56b5900574353657b255ce).
Flags: needinfo?(Virtual)
Whiteboard: [gfx-noted]
Regression range is proper (double-checked now) and patches from bug #1382680 wasn't completely backed out in test build provided in Comment 19.
>(Peter Chang[:pchang] wrote in comment #19)
>> [...]I made some changes with the latest master(not backed out bug 1382680)
A note of explanation. fThis is something of an edge case, not a broad impact on many users, we can't reproduce it, it's from a regression over a year ago, and isn't going to be a priority for the graphics team. Unless we started seeing many more reports of this or the problem gets worse, this is marked "fix-optional" and gfx-noted.  Marking it fix-optional means it will not be included in the weekly regression engineering triage sessions. 

That basically means we'd take a patch, but we don't want to keep re-triaging the bug.

Bulk change for all regression bugs with status-firefox67 as 'fix-optional' to be marked 'affected' for status-firefox68.

[bulk change 69 status -> --- b/c to stop re-triaging old regressions every release]

Triage Owners: please do not set release status tracking flags in new releases unless this bug will actually be worked on

You need to log in before you can comment on or make changes to this bug.