Avoid re-entry in async tab switcher's onUnloadTimeout

RESOLVED DUPLICATE of bug 1385453

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1385453
8 months ago
8 months ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

In bug 1385453, I landed a patch that makes it so that postActions can call into onUnloadTimeout synchronously.

onUnloadTimeout itself calls into postActions, so there's some re-entrancy here.

It'd be better if we could avoid this by factoring out most onUnloadTimeout into a helper function. Then, onUnloadTimeout can run preActions / helper / postActions, and postActions can just call the helper without causing re-entry.
Assignee: nobody → mconley
Turns out I'm just fixing this in bug 1385453.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385453
You need to log in before you can comment on or make changes to this bug.