Closed Bug 1392920 Opened 4 years ago Closed 3 years ago

Some background colors not being painted

Categories

(Core :: Graphics: WebRender, defect, P2)

x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected

People

(Reporter: hsivonen, Unassigned)

References

()

Details

(Whiteboard: [wr-reserve] [gfx-noted])

Attachments

(2 files)

With Stylo and WebRender enabled (but not with Stylo enabled and WebRender disabled), some background colors don't get painted.

These include:
 * The background for the <html> element at https://hsivonen.fi/ (minor)
 * The background for label badges in Gmail message list view (minor)
 * The login button on Discourse (e.g. https://users.rust-lang.org/) (major problem, button invisible)
 * The message send button on Discourse (major problem, button invisible)
 * The background of the message composition UI on Discourse (medium, looks very broken but can be used)
Hm, I tried these two:
>  * The background for the <html> element at https://hsivonen.fi/ (minor)
>  * The login button on Discourse (e.g. https://users.rust-lang.org/) (major
> problem, button invisible)

in a clean profile on OS X Nightly with stylo+webrender enabled, but the pages seem to render fine for me. Can you try in a clean profile and see if you can still repro?
Whiteboard: [gfx-noted]
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
Priority: P2 → P3
Whiteboard: [wr-mvp] [gfx-noted] → [wr-reserve] [gfx-noted]
Hi,

Same problem on Linux with nvidia drivers, this doesn't happen on intel graphics though, so probably nvidia only bug, many websites are broken as a results, I'll upload a few screenshots.

F.
weather underground
I don't know if this is worth mentioning but this does not happen on the same machine with servo-nightly.
I do see the same thing on Linux with an nVidia GPU (and proprietary drivers), though I want to note that it also affects the active tab background color.
So do I.  I got below messages when launching firefox.

[GLX] window 4e0001c has VisualID 0x92
Could not find symbol "glDeleteFencesAPPLE" by glcontext
Could not find symbol "glFinishFenceAPPLE" by glcontext
Could not find symbol "glFinishObjectAPPLE" by glcontext
Could not find symbol "glGenFencesAPPLE" by glcontext
Could not find symbol "glGetTexParameterPointervAPPLE" by glcontext
Could not find symbol "glInsertEventMarkerEXT" by glcontext
Could not find symbol "glIsFenceAPPLE" by glcontext
Could not find symbol "glPopGroupMarkerEXT" by glcontext
Could not find symbol "glPushGroupMarkerEXT" by glcontext
Could not find symbol "glSetFenceAPPLE" by glcontext
Could not find symbol "glTestFenceAPPLE" by glcontext
Could not find symbol "glTestObjectAPPLE" by glcontext
Could not find symbol "glTextureRangeAPPLE" by glcontext
WebRender - OpenGL version new 3.2.0 NVIDIA 384.111
Linux nvidia driver specific problem seems to be addressed by Bug 1401455.
Works for me :D
(In reply to Henri Sivonen (:hsivonen) from comment #0)
> With Stylo and WebRender enabled (but not with Stylo enabled and WebRender disabled), some background colors don't get painted.

Can you still reproduce this or can we close this bug?
Flags: needinfo?(hsivonen)
Can't repro anymore.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(hsivonen)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.