System tray mail notification state incorrect

VERIFIED DUPLICATE of bug 133130

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 133130
16 years ago
14 years ago

People

(Reporter: Jim Garrison, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

Under certain specific conditions, documented below, the BIFF icon
in the system tray gets out of sync with the actual state of
unread mail.  This *appears* to happen only if you click too quickly
on the newly arrived mail, while the pop-up "User has n new messages"
notification window is still displayed above the system tray.

Reproducible: Always
Steps to Reproduce:
1. Make sure mail is configured to check periodically for new mail
2. Send yourself mail and wait for it to arrive (don't click "Get Mail")
3. Quickly, while the "slide-up" mail notification widget is still
   displayed (i.e. within about 3-4 seconds of receiving the mail)
   click on the new mail message.


Actual Results:  
1) New mail icon remains in system tray, even though there is no
   new mail.
2) Whenever new mail arrives after this point, the popup mail
   notification window does not display.  

Expected Results:  
1) Mail notification icon disappears, and reappears next time mail
   arrives.
2) Popup notification window appears the next time mail
   arrives.

The behavior described above does not happen if you wait until the
notification popup window disappears before clicking on the new 
mail message to read it.

Comment 1

16 years ago
You are experiencing bug 133130, which has recently been fixed.
You will need to download a recent nighly build in order to not to have this
problem anymore.

*** This bug has been marked as a duplicate of 133130 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: olgam → stephend
verified dup.

reporter: if you can still reproduce this in a nightly build, please re-open bug
133130 with steps to reproduce.  Thanks
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.