Awesome bar hover state (border, box-shadow) should be consistent with back button

VERIFIED FIXED in Firefox 57

Status

()

enhancement
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: epang, Assigned: daleharvey)

Tracking

(Blocks 1 bug)

57 Branch
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 attachments)

Reporter

Description

2 years ago
Currently the hover state state of the awesome bar is slightly darker then the back button.

Can we update and align the stroke and drop shadow to the back button specifications?
Priority: -- → P4
Summary: Awesome bar hover state should be consistent with back button → Awesome bar hover state (border, box-shadow) should be consistent with back button
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
Assignee

Updated

2 years ago
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify?
Priority: P4 → P1
Comment hidden (mozreview-request)
Assignee

Comment 2

2 years ago
I specifically set that box shadow in https://bugzilla.mozilla.org/show_bug.cgi?id=1352366 however I cant remember why, its not in the spec and not mentioned in the comments as far as I can see. 

Thats the only difference between the url bar and the back button, they otherwise match the spec

Comment 3

2 years ago
mozreview-review
Comment on attachment 8903686 [details]
Bug 1393054 - Remove extra box-shadow from urlbar.

https://reviewboard.mozilla.org/r/175408/#review180702
Attachment #8903686 - Flags: review?(dao+bmo) → review+

Comment 4

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c4c81a8b699
Remove extra box-shadow from urlbar. r=dao
https://hg.mozilla.org/mozilla-central/rev/7c4c81a8b699
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
I verify this issue on Windows 10 x64 using Nightly 58.0a1 with build ID 20171001220301 and the conclusion was that the hover state of the awesome bar, the color is darker (#F0F0F0) than the build with the old version of 2017.08.24 (#F2F2F2).
This is the result you are expecting?
Flags: needinfo?(dao+bmo)
Posted image aa.bmp
I tested this problem using Nightly 58.0a1 with the build ID 20171002100134 on Windows 10 x64 and Windows 7 x64 and I see no difference, but on Mac OS 10.12 and Ubuntu 16.04, the problem is resolved.
Flags: needinfo?(aryx.bugmail)
Sorry, about my mistake! Please ignore this comment.
Flags: needinfo?(aryx.bugmail)
(In reply to Valentina Claudia Ona from comment #6)
> I verify this issue on Windows 10 x64 using Nightly 58.0a1 with build ID
> 20171001220301 and the conclusion was that the hover state of the awesome
> bar, the color is darker (#F0F0F0) than the build with the old version of
> 2017.08.24 (#F2F2F2).
> This is the result you are expecting?

No, the location bar's hover box-shadow was darker, should be lighter now to match the back button.
Flags: needinfo?(dao+bmo)
I tested on Mac OS X 10.10 with a build before the fix and with the latest Nightly build 58.0a1(2017-10-03) and I don't see any differences. Eric, can you please give us more details about this issue, on what OS did you encounter this issue and other details that can help us verify this. Thanks
Flags: needinfo?(epang)
Reporter

Comment 11

2 years ago
Hi Ovidiu, it was a subtle change but it looks good now.  Thanks!
Flags: needinfo?(epang)
Thanks Eric for your reply, can you please tell me on what FF version did you test this, I assume FF Nightly 58.0a1. But just to be on the same page we would appreciate if you can make a screen recorder or a print screen to see how to verify this issue. Thanks
Flags: needinfo?(epang)
Since Eric reported the bug, I think his word is good enough to mark this verified. Thanks!
Status: RESOLVED → VERIFIED
Flags: needinfo?(epang)
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.