Sound not working on lightweight Linux

RESOLVED DUPLICATE of bug 1345661

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1345661
6 months ago
6 months ago

People

(Reporter: RTK, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170816210634

Steps to reproduce:

Using an ALSA-only Linux, mostly used on embedded systems and low resources computers. Access some website with elements that produces sound, it can be a music, a video, a notification that make noise, or any other kind of audio.


Actual results:

No sound is produced and shows up an message requiring PulseAudio installation, an extra server daemon that runs over ALSA managing audio.


Expected results:

As any other multimedia application does, it is expected to produce audio using current ALSA sound provider.
(Reporter)

Comment 1

6 months ago
I beg you to enable ALSA by default and maintain it working for the sake of lightweight community.

If you want to avoid "multiple audio backends" you are doing it wrong, once PulseAudio depends on ALSA, have you ever tried to uninstall libasound2? The application may be easier to maintain, but the system pay the price, if you want to drop some backend, then drop PA and stick with ALSA, once every system that have PA requires ALSA.

Another good reason is not to lose audience, once other browsers is maintaining ALSA support, the problem is most of them are not necessarily lightweight. And there is a plenty of lightweight browsers that does not even support multimedia.

I have being strong on my choice for Firefox, but dropping ALSA support is forcing me to look for alternatives, please, I beg you to reconsider the decision.
(Reporter)

Updated

6 months ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
See https://groups.google.com/forum/#!topic/mozilla.dev.platform/jRAqSTri66I
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345661

Comment 3

6 months ago
The link provided by Anthony Jones does not resolve anything.

The comment by ajo is also irrelevant - the old code for ALSA already used to work just fine.

If mozilla does not want to support it, I am sure that others can help keep it updated, rather
than force users into the same mindset that has led to systemd assimilation.

ALSA should be a possibility but we are blocked here by some people in Mozilla who do not
care about users - including me - who want to use ALSA. ALSA works perfectly well for my 
use case and it used to work perfectly well in firefox too, until these attempts to take
away what users want to have.

Since it is not possible to communicate with people such as ajo, I would like to ask ajo to:

a) Keep these issues OPEN rather than force-close them all. It is YOUR personal opinion, NOT
the opinion of users who have been using firefox for many years but now are forced to use
something else BECAUSE YOU DECIDED ONTO THEM.

b) For mozilla to reconsider what they want to have in the long run altogether. There is no
need for PulseAudio at all other than some people in mozilla thinking they must punish users
with options that they never wanted to have in the first place.

In the days of HTML and CSS being everywhere, and widget design being easy, I am sure a
simple option in about:config or similar would work perfectly well.
You need to log in before you can comment on or make changes to this bug.