All users were logged out of Bugzilla on October 13th, 2018

Pressed link text color should match the spec

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: hani.yacoub, Assigned: evanxd)

Tracking

(Blocks: 1 bug)

57 Branch
Firefox 57
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox55 unaffected, firefox56 unaffected, firefox57 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8900611 [details]
pressed link text.png

[Affected versions]: 
Nightly 57.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox.
2. Go to "about:preferences".
3. Press on any "Learn more" link.

[Expected result]:
Pressed link text color should be blue.

[Actual result]:
Pressed link text color is orange.
(Reporter)

Updated

a year ago
Blocks: 1357306
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
Whiteboard: [photon-preference][triage]

Updated

a year ago
Flags: qe-verify+
Priority: -- → P2
QA Contact: hani.yacoub
Whiteboard: [photon-preference][triage] → [photon-preference]
(Assignee)

Comment 1

a year ago
Created attachment 8901009 [details]
link-is-blue.png

Hi Hani,

I could not reproduce this bug. The link is build. You could see that in the attachment.

Thank you.
(Assignee)

Updated

a year ago
Flags: needinfo?(hani.yacoub)
(Assignee)

Comment 2

a year ago
Hi Hani,

Sorry, I misunderstood previously. I understand what what we should fix now.

Thank you.
Flags: needinfo?(hani.yacoub)
(Assignee)

Updated

a year ago
Assignee: nobody → evan
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Attachment #8901142 - Flags: review?(mconley)
(Assignee)

Comment 5

a year ago
Hi Mike,

Could you help review the patch?

And color color spec info in mentioned in this page[1].

Thank you.

[1]: https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/244683136

Comment 6

a year ago
mozreview-review
Comment on attachment 8901142 [details]
Bug 1393354 - Update the color code of in-content link's normal, hover, and active stages to match Photon visual spec.

https://reviewboard.mozilla.org/r/172614/#review178020

Thanks, looks good, and matches spec - but didn't apply cleanly when I tested it locally. You'll likely need to rebase.
Attachment #8901142 - Flags: review?(mconley) → review+
Comment hidden (mozreview-request)
(Assignee)

Comment 8

a year ago
Hi Mike,

Thank you for the review.

And I rebased the patch.

Let's land it.
Keywords: checkin-needed

Comment 9

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9e5463eb98bc
Update the color code of in-content link's normal, hover, and active stages to match Photon visual spec. r=mconley
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9e5463eb98bc
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
(Reporter)

Comment 11

a year ago
Build ID: 20170829100404
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Verified as fixed on Firefox Nightly 57.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.