Closed Bug 1393458 Opened 2 years ago Closed 2 years ago

"E_First_Run" and "E_Second_Run" is not triggered after launching Firefox a second time

Categories

(Firefox for iOS :: General, defect, P1)

Other
iOS
defect

Tracking

()

VERIFIED FIXED
Iteration:
1.29
Tracking Status
fxios 8.3 ---
fxios-v8.3 --- verified
fxios-v10.0 --- verified

People

(Reporter: SimonB, Assigned: bmunar)

References

Details

(Whiteboard: [MMA] [MobileCore])

Attachments

(1 file)

PR
55 bytes, text/x-github-pull-request
farhan
: review+
Details | Review
Build: master bbaa76973a
Device: iPad Air 2
iOS: 10.3.3

Steps to reproduce;
1. Clean install Firefox
2. Launch Firefox for the first time
3. Close Firefox
4. Launch Firefox a second time
5. Check the Leanplum event trail

Actual results:
- App is correctly launched but the event "E_Second_Run" is not displayed in the event trail.

Expected results:
- "E_Second_Run" should be displayed in the event trail when launching Firefox for the second time.
This is probably a race condition - we call first and second run very soon after intializing LP, so when we previously tested we may have been getting lucky and seeing the first run event. This needs to be wrapped in a onStartResponse call like the pocket and focus events.
Attached file PR
Attachment #8901981 - Flags: review?(sdaswani)
Assignee: nobody → bmunar
Duplicate of this bug: 1393457
Summary: "E_Second_Run" is not triggered after launching Firefox a second time → "E_First_Run" and "E_Second_Run" is not triggered after launching Firefox a second time
Attachment #8901981 - Flags: review?(sdaswani) → review?(fpatel)
Iteration: --- → 1.29
Priority: -- → P1
Whiteboard: [MMA] → [MMA] [MobileCore]
master https://github.com/mozilla-mobile/firefox-ios/commit/5d9a0cc11573dea22633af8113aa55d471fd94a5
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
uplifted to 8.x as well.
uplifted to 9.x too
Verifying as fix on master 631c2932d3c81e. The events are firing correctly on the first and second run.
Attachment #8901981 - Flags: review?(fpatel) → review+
Verifying as fix on beta 8.3(5817).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.