Closed Bug 1393633 Opened 3 years ago Closed 2 months ago

Text selection cannot start on (or just after) the number of an ordered list

Categories

(Core :: DOM: Selection, defect, P3)

52 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 12460
Tracking Status
firefox57 --- wontfix

People

(Reporter: vincent-moz, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170809204109

Steps to reproduce:

1. Open a HTML file containing: <ol><li><a href="http://localhost/">This is a link</a>.</li></ol>
2. Try to select the beginning of the text of the link, starting just before the link.


Actual results:

Nothing happens (nothing is selected).


Expected results:

The text should be selected.

Note: If one starts before the "1.", this works, but doing this is counterintuitive.
Summary: Text selection cannot start on the number of an ordered list → Text selection cannot start on (or just after) the number of an ordered list
Attached file Test case
Component: Untriaged → Selection
Product: Firefox → Core
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 12460

Note, since this is not clear in bug 12460 (which is mainly about selecting generated content): I'm not trying to select generated content here, just normal text that follows generated content, and this does not work because I start the selection over generated content.

The problem with the test case I've provided is that one has generated content immediately followed by a link. So, if I try to start the selection just before the boundary, I cannot select anything since this starts over GC (this is this bug). And if I try to start the selection just after the boundary, this doesn't work because this is a link and Firefox wants to do drag & drop.

Bug 490805 might be related more closely, but that in turn is a duplicate of bug 12460, too, so there we are.

As for the problem specifically in relation to links - you can select text within links by holding Alt while selecting.

I know about Alt, but from an accessibility point of view, Alt requires 2 hands (in addition to needing to have a look at the keyboard and/or wasting time to find the Alt key), while normal selection requires only one hand and can be done more quickly. That's why I usually try to start the selection before the link. And this is where this bug occurs.

You need to log in before you can comment on or make changes to this bug.