Changes to e10srollout for 100% multi on Release 55

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mrbkap, Assigned: mrbkap)

Tracking

54 Branch
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox55 fixed, firefox56 fixed, firefox57 fixed)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Assignee)

Description

a year ago
The go/no-go decision to move to 100% multi on Release 55 is tomorrow and I haven't seen or heard anything to suggest that we won't go. Let's get our ducks in order to be ready for the rollout.

e10srollout is currently at 2.0 on Release and 2.15 on Beta. The two versions are pretty different, as patches have landed on Beta and not Release. I think we should land separate patches on Beta and Release and the GoFaster addon we push will be based on the Release version.
(Assignee)

Updated

a year ago
Assignee: nobody → mrbkap
(Assignee)

Comment 1

a year ago
Created attachment 8900953 [details] [diff] [review]
Patch for beta
(Assignee)

Comment 2

a year ago
Comment on attachment 8900953 [details] [diff] [review]
Patch for beta

This is the Beta patch.
Attachment #8900953 - Attachment description: Changes to move to 100% multi on Release 55 → Patch for beta
Attachment #8900953 - Flags: review?(felipc)
(Assignee)

Comment 3

a year ago
Created attachment 8900954 [details] [diff] [review]
Patch for Release

The new version number should be less than the version number for Beta, I think.
Attachment #8900954 - Flags: review?(felipc)
(Assignee)

Comment 4

a year ago
I'm holding off on writing a patch for Nightly until we're sure we're not just nuking the addon entirely there. We should make that call tomorrow and I'll update the bug here when I do.
(Assignee)

Comment 5

a year ago
After talking to Felipe, we decided to make a couple of small changes:
  - I had changed the "beta" percentages in the patch for Release in order to synchronize the code a bit. However, given past history synchronizing the code in this extension and the fact that the change should never have any effect, I'm going to remove that and let the "beta" changes roll along with the changes.
  - We're going to bump the version number to 3.0 for e10srollout on version 56 and give 2.* entirely to version 55. That gives us more numbers to use and should hopefully be more clear than an arbitrary cutoff at 2.15.
(Assignee)

Comment 6

a year ago
Created attachment 8901922 [details] [diff] [review]
New patch for beta
Attachment #8901922 - Flags: review?(felipc)
(Assignee)

Comment 7

a year ago
Created attachment 8901923 [details] [diff] [review]
New patch for Release
Attachment #8901923 - Flags: review?(felipc)
(Assignee)

Updated

a year ago
Attachment #8900953 - Attachment is obsolete: true
Attachment #8900953 - Flags: review?(felipc)
(Assignee)

Updated

a year ago
Attachment #8900954 - Attachment is obsolete: true
Attachment #8900954 - Flags: review?(felipc)
Attachment #8901922 - Flags: review?(felipc) → review+
Attachment #8901923 - Flags: review?(felipc) → review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed

Comment 8

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c37e9b2f205b
Changes to move to 100% multi on Release 55. r=Felipe
Keywords: checkin-needed
(Assignee)

Comment 9

a year ago
Comment on attachment 8901922 [details] [diff] [review]
New patch for beta

Approval Request Comment
[Feature/Bug causing the regression]: e10s-multi
[User impact if declined]: We won't roll out to 100% of eligible users when Beta becomes Release.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: We have test plans in place.
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: No.
[Why is the change risky/not risky?]: We have been monitoring our data closely and do not believe that we have significant risk here.
[String changes made/needed]: n/a
Attachment #8901922 - Flags: approval-mozilla-beta?
(Assignee)

Comment 10

a year ago
Comment on attachment 8901923 [details] [diff] [review]
New patch for Release

Approval Request Comment
[Feature/Bug causing the regression]: e10s-multi
[User impact if declined]: We won't go to 100% eligible multi on Release 55.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: We have test plans in place.
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: No.
[Why is the change risky/not risky?]: We have been monitoring our data closely and do not believe that we have significant risk here.
[String changes made/needed]: n/a

NB: We intend to release this as a GoFaster addon update.
Attachment #8901923 - Flags: approval-mozilla-release?
(Assignee)

Comment 11

a year ago
Created attachment 8902019 [details]
e10srollout@mozilla.org-2.05.xpi

This is the addon that I intend to get signed for the GoFaster update. It will match the code checked into Release 55 after attachment 8901923 [details] [diff] [review] lands.
Attachment #8902019 - Flags: review?(felipc)
Attachment #8902019 - Flags: review?(felipc) → review+
(Assignee)

Comment 12

a year ago
Jason, can you sign the attachment in comment 11?
Flags: needinfo?(jthomas)
Created attachment 8902381 [details]
e10srollout@mozilla.org-2.05.xpi signed

Please see attached.
Flags: needinfo?(jthomas)
https://hg.mozilla.org/mozilla-central/rev/c37e9b2f205b
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
status-firefox55: --- → affected
status-firefox56: --- → affected
Comment on attachment 8901922 [details] [diff] [review]
New patch for beta

As agreed, let's uplift this so we will get more users on e10s multi.
Attachment #8901922 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 16

a year ago
Rehan, can we get the signed xpi in comment 13 up on the testing channel with no throttling?
Flags: needinfo?(rdalal)

Comment 17

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/f659c6fe6ca8
status-firefox56: affected → fixed
Rules have been updated in Balrog and pending QE/relman signoff.
Flags: needinfo?(rdalal) → needinfo?(lhenry)
Sorry rolled back on "release" no sign off necessary. This is only on the testing channel "release-sysaddon".
Flags: needinfo?(lhenry)
(Assignee)

Updated

a year ago
Flags: needinfo?(jcristau)
Looks like Cornel Ionce sent a test report from the release-sysaddon channel on September 7; I believe this is ready to roll out to the release channel.
Flags: needinfo?(jcristau) → needinfo?(rdalal)
This is in balrog and pending sign off from QA/relman.

The updated rule also includes:
https://bugzilla.mozilla.org/show_bug.cgi?id=1391210
Flags: needinfo?(rdalal)
Flags: needinfo?(lhenry)
Flags: needinfo?(jcristau)
Liz signed off for relman, Cornel just did for qe, so release 55 is now getting the following at 100%:

    "clicktoplay-rollout@mozilla.org-1.3",
    "e10srollout@mozilla.org-2.05",
    "followonsearch@mozilla.com-0.9.3",
    "onboarding@mozilla.org-0.1",
    "screenshots@mozilla.org-10.12.0"
Flags: needinfo?(lhenry)
Flags: needinfo?(jcristau)
Comment on attachment 8901923 [details] [diff] [review]
New patch for Release

no more 55 dot releases planned, and 56 is about to go on m-r.
Attachment #8901923 - Flags: approval-mozilla-release? → approval-mozilla-release-
I'll call this fix in 55 anyway since the system add-on was shipped.
status-firefox55: affected → fixed
You need to log in before you can comment on or make changes to this bug.