[10.13] Force Touch doesn't work in MacOS High Sierra and MacBook

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
a year ago
5 months ago

People

(Reporter: github, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community})

57 Branch
x86_64
Mac OS X
nightly-community
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 wontfix, firefox56 wontfix, firefox57 fix-optional)

Details

(URL)

(Reporter)

Description

a year ago
Steps to Reproduce:
1) Open https://en.m.wikipedia.org/wiki/Mozilla
2) Mark the word Mozilla in the second paragraph
3) Force Click on it

Expected Results:
Native dictionary look up opens

Actual Results:
Nothings happens

My hard- & software configurations:
MacOS 10.13 17A344b build
Nightly Build 2017-08-24
MacBook 12 inch 2017 model
(Reporter)

Updated

a year ago
Not reproduce on my macOS 10.12.6
(Reporter)

Updated

a year ago
Keywords: nightly-community
Works for me too on 10.12.6.

May this be something specific with 10.13? Maybe something changed around ForceTouch; are there release notes of changes?
This works for me on 10.13, B7: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0. I have MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports).

It looks like the difference is I am running 17A352a and you are running 17A344b build. Please update to the latest beta and see if you can still reproduce.
(Reporter)

Comment 4

a year ago
Just updated to the 17A352a build and I'm still able to reproduce the issue.
Can maybe one with a MacBook 12 Retina (2016 or 2017) try to reproduce this issue?
Summary: Force Touch don't work in MacOS High Sierra and MacBook → [10.13] Force Touch doesn't work in MacOS High Sierra and MacBook

Updated

11 months ago
status-firefox55: --- → wontfix
status-firefox56: --- → wontfix
status-firefox57: --- → fix-optional

Updated

11 months ago
Priority: -- → P5

Comment 5

11 months ago
(In reply to Patrick Albrecht from comment #4)
> Just updated to the 17A352a build and I'm still able to reproduce the issue.
> Can maybe one with a MacBook 12 Retina (2016 or 2017) try to reproduce this
> issue?

Although I use 10.13 GA with MacBook Early 2016, I cannot reproduce this.
(Reporter)

Comment 6

10 months ago
Just tried it again with MacOS High Sierra Build 17A405 and I'm still unable to getting force touch to work in Firefox.
Is there any specific build I can download to get some more verbose logs?
(Reporter)

Comment 7

5 months ago
With a new MacBookPro 13 2017 and Firefox 61.0a1 I'm no longer able to reproduce the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.