Closed Bug 1393940 Opened 2 years ago Closed 2 years ago

Intermittent TEST-UNEXPECTED-TIMEOUT | toolkit/components/extensions/test/xpcshell/test_proxy_scripts.js | Test timed out

Categories

(WebExtensions :: General, defect, P3)

defect

Tracking

(firefox56 disabled, firefox57 disabled, firefox58 disabled, firefox59 disabled, firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox56 --- disabled
firefox57 --- disabled
firefox58 --- disabled
firefox59 --- disabled
firefox60 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(2 files)

Duplicate of this bug: 1394038
36 failures on linux64 !debug:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393940

:andym, this is a timeout on a single test, is this something you can help find an owner for this?
Flags: needinfo?(amckay)
Whiteboard: [stockwell needswork]
Assignee: nobody → mixedpuppy
Flags: needinfo?(amckay)
The proxy code is getting a bit of an overhaul in bug 1381290, lets see how this goes after that.
Depends on: 1381290
This is failing quite frequently. OK to skip it while you work on it?
Attachment #8906011 - Flags: review?(mixedpuppy)
(In reply to Geoff Brown [:gbrown] from comment #12)
> Created attachment 8906011 [details] [diff] [review]
> skip test temporarily
> 
> This is failing quite frequently. OK to skip it while you work on it?

Looks like it's just (or primarily) linux, lets just skip on linux.
Comment on attachment 8906011 [details] [diff] [review]
skip test temporarily

r+ to skip on linux only
Attachment #8906011 - Flags: review?(mixedpuppy) → review+
OK, will change to linux only. Thanks.
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e532e8d93b60
Skip xpcshell test_proxy_scripts.js on linux for frequent intermittent timeouts; r=mixedpuppy
Keywords: leave-open
Whiteboard: [stockwell needswork] → [stockwell disabled]
Priority: P5 → P3
Given the try results and that the test file was rewritten, I'm going to land the patch turning this test back on.
Comment on attachment 8946933 [details]
Bug 1393940, reenable proxy script tests which were rewritten in bug 1381290

https://reviewboard.mozilla.org/r/216778/#review222580
Attachment #8946933 - Flags: review+
Pushed by mixedpuppy@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/30289633138d
reenable proxy script tests which were rewritten in bug 1381290 r=mixedpuppy
The test was re-enabled over 2 weeks ago and I don't see any new intermittents recorded for it, so I'm marking this fixed.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: [stockwell disabled] → [stockwell fixed]
Keywords: leave-open
Target Milestone: --- → mozilla60
Flags: qe-verify-
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.