Incorrect menu item/submenu handling of mouse clicks

VERIFIED DUPLICATE of bug 130855

Status

()

Core
XUL
--
minor
VERIFIED DUPLICATE of bug 130855
17 years ago
10 years ago

People

(Reporter: David Cuthbert, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If a menu item contains a submenu -- for example, the View / Text Zoom menu item
-- it does not respond correctly if the menu item is clicked to reveal the
submenu.  It responds correctly if the pointer hovers over the menu item.

What I'm doing and what I'm seeing:
1. In the browser, click on the View menubar item.
2. The view menu (Show/Hide, a separator, Stop, Reload, separator, etc.) appears.
3. Move the pointer down to Text Zoom.
4. Click on Text Zoom.
5. The submenu may or may not appear.
6. The browser window zooms to 75% width.


If step 4 is omitted, then the submenu appears as expected, and the items there
can be picked as normal.


This also happens with other menus (View / Show/Hide, Tools / Form Manager, etc.).

For some reason, bugzilla isn't capturing the version.  This is 1.0rc1.

Comment 1

17 years ago
Weird. Confirmed on Linux, but does not occur on win32. Only some submenus as 
noted, although it's not obvious what the common thing is.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of "clicking on menuitem with submenu often activates an item on the
submenu"

*** This bug has been marked as a duplicate of 130855 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.