Closed Bug 1394115 Opened 2 years ago Closed 2 years ago

Icons for some localhost bookmark stay as default

Categories

(Firefox :: Bookmarks & History, defect, P2)

55 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1359487
Tracking Status
firefox57 --- fix-optional

People

(Reporter: mahks1, Unassigned)

References

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

With the update to 55.0.3 (32-bit)
Favicons for some localhost bookmarks reverted to xampp default icon.
On loading the bookmark item, the tab icon refreshes to the favicon properly,
The bookmark retains the xampp default (even for phpmyadmin)

But this happened with only about 50% of my localhost bookmarks, some updated properly.

Could find no similarity between those that did or did not update.




Expected results:

All bookmark icons should refresh on load of URL
Seems the URL's that had bookmarks refresh properly all had index.php as the URL file name.
Blocks: 977177
Component: Untriaged → Bookmarks & History
Likely the icon at the root domain (/localhost/favicon.ico) has a better resolution than the other ones.
For the phpmyadmin bookmark, the URL is http://localhost/phpmyadmin/ 

The favicon at that location is the correct "PMA" favicon.ico and is 32 X 32 pixels (this displays on the tab).

The favicon being displayed on the bookmark appears to be the "XAMPP" favicon.ico in C:\xampp\htdocs\dashboard and is 16 X 16 pixels.
There is also C:\xampp\htdocs\favicon.ico "XAMPP" 32 X 32 pixels, 

This probably the "/localhost/favicon.ico" Marco mentioned, but seems to be the same resolution as the correct icon.

But file sizes are different: C:\xampp\htdocs\favicon.ico 30.1 KB
The localhost/phpmyadmin/favicon.ico 21.9 KB
(In reply to Mahks from comment #4)
> There is also C:\xampp\htdocs\favicon.ico "XAMPP" 32 X 32 pixels, 
> 
> This probably the "/localhost/favicon.ico" Marco mentioned, but seems to be
> the same resolution as the correct icon.

Yep, it's likely that one since it's in the root.
Though, if both icons are linked to the same page, and they have same exact size, it's strange that we pick the root one.
Does that ico file only contain a 32x32 frame, or does it contain multiple frames, some of which may even be larger?
Usually for a page we pick both root icon and the page icon, sort them by width desc and then prefer the non-root one. clearly if the root one has a frame larger than the other one, it will be picked first.
You can check the ico frames with an image viewer or an image editor, please check all the frames of the ico file.
The situation may improve when I implement bug 1347532, then the ui should just pick a 32px frame and prefer the non-root one.
I used the phpmyadmin as an example, as others would have that same situation, but my other bookmarks that call localhost pages (and are not refreshing) actually have icon files that have unique names and are png format.

Those bookmarks that call index.php's (and do refresh) also have png icons.

My .png icons are in a subdirectory, if that matters.
Seems to be a related issue, regarding a bookmark to my live server (not a bookmark to a location on my localhost as above)

It has changed to the "X in circle" (see attached image), the center bookmark icon is a link to the external site. When accessed, the tab for site displays the correct icon, but the bookmark remains as the "X in circle". I think the icon changed when the site was down, but remains even though the site is now up again. If I create a new bookmark for the site it has the same "X in circle" icon!

The favicon on the site is : http://www.sw3k.ca/admin/images/icon_admin_live_1.png

Not sure where that "X in circle" icon comes from...
Attached image ff bookmark issue.PNG
we'll look at further icon problems during the 58 cycle.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Whiteboard: [fxsearch]
I am running beta (v58) still an issue. 

Was this fixed? Do I have to do something to refresh the icons? nothing I tried seems to work.

If not fixed, is there a work around? like deleting a cache of those icons somewhere?
Beta is v57, Nightly is v58, at least until tomorrow.

The only remaining thing that could cause that in v58, is the fact sometimes we'll prefer the root icon if it has a better resolution than the local icon. Other bugs should have been fixed.
Sorry it was nightly running. 

So if there is a custom icon that the site uses for an icon ie; 
<link rel="icon" type="image/png" href="images/custom_icon.png">

and the default favicon (which has nothing to do with the site) has better resolution, FF opts for the favicon?

I would think that a custom icon would have preference.
yes, we try to avoid blurry icons, and that sometimes ends up picking the root icon because it can be scaled better, for example the page may not define an icon good for 32x32 (16 px icon on a 2xdpi screen). This area is a little bit under specified. I'm duping to bug 1359487 that is tracking the remaining issue.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359487
You need to log in before you can comment on or make changes to this bug.