Firefox unable to handle magnet links

RESOLVED DUPLICATE of bug 1382323

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 1382323
10 months ago
8 months ago

People

(Reporter: alquimista.ds, Unassigned)

Tracking

({regression, regressionwindow-wanted})

55 Branch
x86_64
Linux
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8901523 [details]
Captura de tela de 2017-07-02 21-51-51.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170826053331

Steps to reproduce:

Tried to download by using a magnet link.


Actual results:

An error page appears instead, saying Firefox cannot open magnet files because it is not associated with any program.


Expected results:

Clicking the magnet link would run Transmission bittorrent client (other torrent clients tested, same results)

No magnet link association is listed in settings.

This bug report I filed to Red Hat Bugzilla explains better:
https://bugzilla.redhat.com/show_bug.cgi?id=1467130

I am a GNU/Linux user. Tried many distros. Reproducible in all of them. This affects recent versions of Firefox, probably started after FF54.

Updated

10 months ago
Component: Untriaged → File Handling

Comment 1

10 months ago
Try https://mozilla.github.io/mozregression/ to find the regression range.
Has Regression Range: --- → no
Has STR: --- → yes
Keywords: regression, regressionwindow-wanted
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
status-firefox57: --- → wontfix

Updated

8 months ago
Duplicate of this bug: 1400803

Comment 3

8 months ago
This may have been fixed by bug 1382323, you can try to install Firefox Nightly to see if the issue is solved there, and reopen the bug if it still occurs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382323
You need to log in before you can comment on or make changes to this bug.