Closed Bug 1394240 Opened 4 years ago Closed 2 years ago

OOP: Links do not work on option page

Categories

(WebExtensions :: Frontend, defect, P3)

56 Branch
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: eros_uk, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170805085114

Steps to reproduce:

Clicking Links on the extension's Option page opens a new blank tab.

After setting 'extensions.webextensions.remote' to false and reloading the option page, the link works fine.
Depends on: webext-oop
Flags: needinfo?(amckay)
I thought this might be a dupe. The only one I can find is bug 1385548 though, so probably not.
Flags: needinfo?(amckay)
Priority: -- → P3
As a test (for confirmation), you can try any of my addons. I include a Support link in addon's Option page.
Product: Toolkit → WebExtensions

I created an extension with an embedded options page, and clicked on a link to https://example.com (and for good measure, also a moz-extension link).

In both cases, the page is loaded as expected (Firefox 65.0.1).

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME

The issue had been fixed for a while now :)
It was an issue in Firefox 56 (I cant recall when it was fixed though)

You need to log in before you can comment on or make changes to this bug.