Closed Bug 1394248 Opened 2 years ago Closed 2 years ago

Update plugins icons in Plugins category/tab in Add-ons Manager/about:addons to Photon specific ones

Categories

(Toolkit :: Add-ons Manager, defect, P1)

57 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: Virtual, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, ux-consistency, Whiteboard: [reserve-photon-visual])

Attachments

(4 files)

Attached image screenshot1.png
Update plugins icons in Plugins category/tab in Add-ons Manager/about:addons to Photon specific ones.
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Flags: qe-verify+
Priority: -- → P4
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Priority: P4 → P1
Sorry Stephen, that time again, we have 2 other plugin icons we use

http://searchfox.org/mozilla-central/source/toolkit/themes/osx/mozapps/plugins/notifyPluginGeneric.png
http://searchfox.org/mozilla-central/source/toolkit/themes/osx/mozapps/plugins/pluginBlocked.png

notifyPluginGeneric we could probably skip updating but pluginBlocked specifically uses the old style so will need a new icon (or can use the current icon but red?)
Flags: needinfo?(shorlander)
Apologies Stephen, when I looked at actually switching the pluginBlocked icon it seems we do not actually use it at all, will deal with that in https://bugzilla.mozilla.org/show_bug.cgi?id=1348556.
Comment on attachment 8916534 [details]
Bug 1394248 - Update plugins icon.

we do use pluginBlocked-64.png though, will do that icon in this patch as well
Attachment #8916534 - Flags: review?(dao+bmo)
Comment on attachment 8916534 [details]
Bug 1394248 - Update plugins icon.

https://reviewboard.mozilla.org/r/187678/#review193176

::: toolkit/themes/shared/non-mac.jar.inc.mn:81
(Diff revision 2)
>  #elif MOZ_SEPARATE_MANIFEST_FOR_THEME_OVERRIDES
>  [extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}] chrome.jar:
>  #endif
>  % override chrome://global/skin/arrow/arrow-lft-hov.gif           chrome://global/skin/arrow/arrow-lft.gif
>  % override chrome://global/skin/arrow/arrow-rit-hov.gif           chrome://global/skin/arrow/arrow-rit.gif
> -% override chrome://mozapps/skin/plugins/notifyPluginCrashed.png          chrome://mozapps/skin/plugins/pluginGeneric-16.png
> +% override chrome://mozapps/skin/plugins/notifyPluginCrashed.png          chrome://mozapps/skin/plugins/pluginGeneric.svg

Overriding a png with an svg doesn't seem like a good idea. Can you update browser-plugins.js to use pluginGeneric.svg directly?

::: toolkit/themes/windows/mozapps/extensions/eula.css:1
(Diff revision 2)
> +

Please don't add this line ;)
Attachment #8916534 - Flags: review?(dao+bmo) → review-
Blocks: 1348556
Comment on attachment 8916534 [details]
Bug 1394248 - Update plugins icon.

https://reviewboard.mozilla.org/r/187678/#review193190
Attachment #8916534 - Flags: review?(dao+bmo) → review+
Duplicate of this bug: 1348556
Comment on attachment 8916534 [details]
Bug 1394248 - Update plugins icon.

Approval Request Comment
[Feature/Bug causing the regression]: Photon polish
[User impact if declined]: User sees old inconsistent icon
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: Nope
[Why is the change risky/not risky?]: icon change with some dead code / asset removal
[String changes made/needed]:
Attachment #8916534 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/4eae12c81330
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Comment on attachment 8916534 [details]
Bug 1394248 - Update plugins icon.

Photon changes (doesn't seem like just polish ;), Beta57+
Attachment #8916534 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 58.0a1 (2017-10-11), so I'm marking this bug as VERIFIED.
Thank you very much! \o/
Status: RESOLVED → VERIFIED
Depends on: 1421711
You need to log in before you can comment on or make changes to this bug.